Leaking oil - Snowblower Forum : Snow Blower Forums
 
LinkBack Thread Tools
post #1 of 4 Old 11-29-2018, 12:45 PM Thread Starter
Member
 
Join Date: Oct 2016
Location: Manitoba, Canada
Posts: 37
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 1
Leaking oil

So I have a Noma snowblower. It has a techumseh 10hp motor. My problem is that oil is leaking out of the breather filter. Doea this just mean I need a new breather.

Sent from my LG-H831 using Tapatalk
bambamshere is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 11-29-2018, 02:00 PM
Member
 
Join Date: Oct 2018
Location: St. James, NY
Posts: 68
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 2
Likes (Received): 6
leaking as blowing out when running? if so look for over filling of the oil, check compression as rings could be shot allowing oil past them and blowing out the breather.
clifish is offline  
post #3 of 4 Old 11-29-2018, 03:21 PM
Super Moderator
 
Kiss4aFrog's Avatar
 
Join Date: Nov 2013
Location: Hudson, WI
Posts: 9,131
Post Thanks / Like
Thanks (Given): 509
Thanks (Received): 680
Likes (Given): 3834
Likes (Received): 1474
Garage
Is the oil level in it's operating range, maybe over full ?? What are the engine numbers ??

If the lever is normal it might be the breather is getting plugged up and sticking or unable to drain back to the engine the oil is separating out of the crankcase vapors.

.

.
Make sure the windows are up before the snow plow goes by !!

Please help keep the lights on by subscribing:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Kiss4aFrog is offline  
post #4 of 4 Old 11-30-2018, 02:01 AM Thread Starter
Member
 
Join Date: Oct 2016
Location: Manitoba, Canada
Posts: 37
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 1
Ok so I know that the rings are ok. I had the motor taken apart last year because it was blowing fire out of the exhaust. Found out that all it needed was new spark plug and carb wasn't adjusted right.

I put gasket kit on it last year. The only thing I didn't do it was the breather on it. It had been sitting for about 5 years at the family farm before I got to it.

Sent from my LG-H831 using Tapatalk
bambamshere is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowblower Forum : Snow Blower Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome