Throttle issue - Snowblower Forum : Snow Blower Forums
 
LinkBack Thread Tools
post #1 of 3 Old 12-18-2016, 01:43 PM Thread Starter
Junior Member
 
Join Date: Dec 2016
Posts: 1
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 0
Throttle issue

I recently bought an Ariens 1128 - probably 2004 model (not sure how to know). On second use today, I idled it down to move trash cans and when I moved the throttle back up, the engine stayed at idle for several seconds before suddenly reving back up to full throttle where I had positioned it. It did that each time I repeated the throttle down and throttle up, including once where it took 30 seconds or so to rev up.

I haven't tore into it yet to see what might be sticking. I thought I might shorten the learning curve by posting here to see what others might have already discovered about this issue. Any ideas appreciated.
seshore is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 12-18-2016, 01:55 PM
Senior Member
 
POWERSHIFT93's Avatar
 
Join Date: Dec 2013
Location: PARADISE CITY, MN
Posts: 9,600
Post Thanks / Like
Thanks (Given): 508
Thanks (Received): 380
Likes (Given): 291
Likes (Received): 1379
Spray some carb cleaner on the throttle linkage. it sounds like it is binding up in there. ALOHA from the paradise city.

Long LIVE THE POWERSHIFT!! MAY IT NEVER RUST IN PEACE!!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
MAHALO!!!!!!!!!
POWERSHIFT93 is offline  
post #3 of 3 Old 12-18-2016, 02:20 PM
Senior Member
 
Join Date: Nov 2015
Location: Cedar Rapids, Iowa
Posts: 1,239
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 88
Likes (Given): 127
Likes (Received): 280
Yeah - gotta be sticky for some reason - old fuel turns to varnish and does cause stickage problems...... a good cleaning is a good place to start.......




I am deathly allergic to shovels!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
bad69cat is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowblower Forum : Snow Blower Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome