Ariens Deluxe 28 Revving High - Snowblower Forum : Snow Blower Forums
Reply
 
LinkBack Thread Tools
post #1 of 11 Old 04-20-2018, 03:04 AM Thread Starter
Member
 
Join Date: Nov 2015
Posts: 75
Post Thanks / Like
Thanks (Given): 3
Thanks (Received): 5
Likes (Given): 7
Likes (Received): 0
Ariens Deluxe 28 Revving High

Yo so my Deluxe 28 started revving really high and sounds somewhat violent not surging but just revving much higher than normal. Could this be caused by the belts? When I took the belt cover off the top there was quite a bit of black rubber. The belts don't look terrible to me but I don't really know what I am looking for. They don't look frayed but maybe the drive belt is a little worn but the auger belts look pretty good. Any ideas?

Also how do you get the throttle/choke knob off does it just pull straight up? Seems like it wants to break if pulled too hard.
Attached Thumbnails
Click image for larger version

Name:	throttle snowblower.jpg
Views:	35
Size:	205.5 KB
ID:	143194  
ICECOLDBEER is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 04-20-2018, 03:10 AM Thread Starter
Member
 
Join Date: Nov 2015
Posts: 75
Post Thanks / Like
Thanks (Given): 3
Thanks (Received): 5
Likes (Given): 7
Likes (Received): 0
Heres some pictures. A lot of rubber... can't tell the condition of the belts in these but they don't seem terrible to me. Could a worn belt cause the engine to rev high or am I off base and something is wrong with the engine it self? Gonna try to get a video. I am afraid to run it for too long don't want to damage it further.
Attached Thumbnails
Click image for larger version

Name:	thumbnail_IMG_2792.jpg
Views:	51
Size:	25.1 KB
ID:	143202   Click image for larger version

Name:	thumbnail_IMG_2791.jpg
Views:	43
Size:	18.8 KB
ID:	143210  
ICECOLDBEER is offline  
post #3 of 11 Old 04-20-2018, 10:11 AM
Senior Member
 
Join Date: Nov 2016
Location: Massachusetts
Posts: 1,632
Post Thanks / Like
Thanks (Given): 12
Thanks (Received): 110
Likes (Given): 112
Likes (Received): 254
Not sure on the revving but the choke knob has a little plastic tab that clips in a hole on the carb lever, Best I do is wiggle it and hope for the best, fuel shutoff is the same, Broke one on the fuel but needed to replace the shutoff anyway and made sure to order one with a knob, but once you get that off the throttle knob just slides off, Choke knob holds it on so no issues getting that off.

Sno-Tek Modded, 15"X-Track tires (Now has same X-Track tires but 13"x4" for better fit), 254cc engine LED light and hand warmers.
Snapper 6/22 sold but not forgotten. Was my first.
Ariens ST1027LE workhorse and going strong.
New 2017 Ariens Deluxe completely rebuilt after losing a fight with a forklift.
Dauntae is online now  
post #4 of 11 Old 04-20-2018, 11:23 AM
Senior Member
 
tpenfield's Avatar
 
Join Date: Feb 2015
Location: Massachusetts
Posts: 1,042
Post Thanks / Like
Thanks (Given): 48
Thanks (Received): 56
Likes (Given): 127
Likes (Received): 191
Garage
I would be checking out the throttle and governor linkages for the high revving.

The belts are probably a symptom rather than a cause.

Regards, Ted
.
Current & Past Fleet:
2017 Husqvarna ST224 (SOLD)
2014 Troy-Bilt 2410 w/ Briggs & Stratton 305cc Engine
2003 Ariens ST824LE (SOLD)
1999 Toro PowerShift 824 w/ 318cc OHV Tecumseh Engine
1988 Toro 521 w/ 212cc Predator Engine
1985 Toro 3521 w/ 179cc Powermore Engine (SOLD)
tpenfield is online now  
post #5 of 11 Old 04-20-2018, 01:54 PM Thread Starter
Member
 
Join Date: Nov 2015
Posts: 75
Post Thanks / Like
Thanks (Given): 3
Thanks (Received): 5
Likes (Given): 7
Likes (Received): 0
Quote:
Originally Posted by tpenfield View Post
I would be checking out the throttle and governor linkages for the high revving.

The belts are probably a symptom rather than a cause.
Thanks for the reply. The linkages are all connected properly and turning the engine speed knob does increase the rpm and turn the governor. It just sounds so violent. Anything specific I should be looking for with the linkages?

Going to post a video soon.

I noticed the oil seems a little over filled and there is some white sludgy stuff on the cap and top of fill tube. Could this be the problem?
ICECOLDBEER is offline  
post #6 of 11 Old 04-20-2018, 01:58 PM Thread Starter
Member
 
Join Date: Nov 2015
Posts: 75
Post Thanks / Like
Thanks (Given): 3
Thanks (Received): 5
Likes (Given): 7
Likes (Received): 0
Not sure why some files will attach here and other wont... here are some picture of the linkages but I think the are fine

https://imgur.com/a/23eTlFs
ICECOLDBEER is offline  
post #7 of 11 Old 04-20-2018, 02:01 PM Thread Starter
Member
 
Join Date: Nov 2015
Posts: 75
Post Thanks / Like
Thanks (Given): 3
Thanks (Received): 5
Likes (Given): 7
Likes (Received): 0

Here is a video of the blower. I guess its not really revving high its just so loud. Keep in mind this is at Idle speed its much louder if you turn the speed up
ICECOLDBEER is offline  
post #8 of 11 Old 04-20-2018, 04:22 PM
Senior Member
 
tpenfield's Avatar
 
Join Date: Feb 2015
Location: Massachusetts
Posts: 1,042
Post Thanks / Like
Thanks (Given): 48
Thanks (Received): 56
Likes (Given): 127
Likes (Received): 191
Garage
So it is not revving high . . . just making a noise.

Remove the belts and see if it still makes the noise. If so, you know it is not the belts. Does not sound good though . . .

Regards, Ted
.
Current & Past Fleet:
2017 Husqvarna ST224 (SOLD)
2014 Troy-Bilt 2410 w/ Briggs & Stratton 305cc Engine
2003 Ariens ST824LE (SOLD)
1999 Toro PowerShift 824 w/ 318cc OHV Tecumseh Engine
1988 Toro 521 w/ 212cc Predator Engine
1985 Toro 3521 w/ 179cc Powermore Engine (SOLD)
tpenfield is online now  
post #9 of 11 Old 04-20-2018, 05:52 PM
Senior Member
 
Join Date: Mar 2015
Location: nova scotia-south shore - ave annual snowfall 199.4 cm ( 78.5 ")
Posts: 2,325
Post Thanks / Like
Thanks (Given): 73
Thanks (Received): 157
Likes (Given): 366
Likes (Received): 597
Garage
i will agree, its not revving high, just sounds like a terrible rattle in something, hopefully its not engine internals.

24 " 1967? Ariens Sno thro
28 " Ariens Sno Tek
Toro CCR ss
1966 Gravely LI Walk behind with dog eater

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
nwcove is online now  
post #10 of 11 Old 04-21-2018, 12:55 PM
Super Moderator
 
Kiss4aFrog's Avatar
 
Join Date: Nov 2013
Location: Hudson, WI
Posts: 9,145
Post Thanks / Like
Thanks (Given): 511
Thanks (Received): 682
Likes (Given): 3849
Likes (Received): 1479
Garage
I can hear a tinny noise which usually is a bearing. I'd check that tensioner pulley with the belt off, the one right under the crankshaft pulley. Just give it a spin and see if it makes noise.
Secondly the bearing down below for the drive disc. There is a knocking that just isn't right in that video. Problem is we pretty much need to be there to find it.

.

.

.
Make sure the windows are up before the snow plow goes by !!

Please help keep the lights on by subscribing:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Kiss4aFrog is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowblower Forum : Snow Blower Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome