Ariens ST 504 no start - Snowblower Forum : Snow Blower Forums
 
LinkBack Thread Tools
post #1 of 2 Old 01-27-2015, 11:37 AM Thread Starter
Member
 
Join Date: Jan 2014
Posts: 80
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 1
Likes (Given): 0
Likes (Received): 1
Ariens ST 504 no start

my Ariens has always started up no problem. I'm pretty good about winterizing my machines at the end of each year. I know I did at the end of last season.

Anyway, we have about 4-6 " here in Pitt. Pulled out the Ariens, and it wouldn't start. I have spark, and compression. Most likely the carb right?

I know I burned off all remaining gas before I stored the machine. Which is why I would be surprised if the carb is gummed up. But I guess its possible. Thoughts?
Relli1130 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 01-27-2015, 02:45 PM
Member
 
Join Date: Oct 2014
Posts: 87
Post Thanks / Like
Thanks (Given): 1
Thanks (Received): 2
Likes (Given): 0
Likes (Received): 1
When you run the carb dry, do you re-start the engine with the choke on? If not, there is a chance your carb ports are clogged from leftover gas.

Compression, spark...all you're missing is fuel! If you can get the engine running temporarily with quick start spray you'll know you have an issue in fuel delivery...tank, hose, filter, and carb would be suspect.
cancon is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowblower Forum : Snow Blower Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome