Ariens 28 Deluxe 921030 running rough - Snowblower Forum : Snow Blower Forums
 
LinkBack Thread Tools
post #1 of 5 Old 10-31-2016, 10:30 AM Thread Starter
Junior Member
 
Join Date: Oct 2016
Posts: 1
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 0
Ariens 28 Deluxe 921030 running rough

This snowblower is under a year old. I have used it 3 times last winter season. On second use, it started cycling throttle up/down. I've pulled it out of storage past weekend, same thing. Bad gas? I took carburetor apart, drained all old gasoline, cleaned it. Drained fuel tank. Replaced gas with new 93 octane, added a little bit of Enzyme fuel stabilizing additive. Same thing. Here's a youtube video I recorded "youtube.com/watch?v=e_fe8kM9Sfs". If anyone would shine some light on this, greatly appreciated.
MadMax is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 10-31-2016, 11:16 AM
Member
 
Join Date: Oct 2016
Location: Northern VA
Posts: 32
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 1
Likes (Given): 1
Likes (Received): 3
Garage
Whoops, wrong thread. Dang phone.

2017 Ariens Deluxe 24 - 921045

Last edited by Scuba_Steve; 10-31-2016 at 11:19 AM.
Scuba_Steve is offline  
post #3 of 5 Old 10-31-2016, 11:00 PM
Junior Member
 
Join Date: Sep 2016
Posts: 23
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 1
Likes (Given): 0
Likes (Received): 2
Did you check the spark plug and the wire? When did you buy it? I'd be calling your dealer and getting warranty work done on it.
Dextar is offline  
post #4 of 5 Old 11-01-2016, 04:06 PM
Junior Member
 
Join Date: Oct 2016
Posts: 29
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 1
Likes (Given): 0
Likes (Received): 4
Throtle up & down

I've had the same problem with the same model. With mine it only happens sometimes. I'll shut it down and let it set for about 10 mins. . Then it restarts and runs fine. The dealer thought it was the gas cap, Replaced and still happened. Ariens thought it was the carb icing. Well, now that doesn't seem to be it.
Ferret is offline  
post #5 of 5 Old 11-01-2016, 08:01 PM
Senior Member
 
Join Date: Jul 2016
Location: CNY
Posts: 485
Post Thanks / Like
Thanks (Given): 12
Thanks (Received): 38
Likes (Given): 11
Likes (Received): 63
OK, here's my two cents. Hard to tell from your video but, if it's running like that at idle and you can smooth it out by giving it some choke it's got an idle screw/passage/jet plugged or partially plugged. If it's doing it at wide open throttle it's the high speed jetting.
Also, since these engines now have to meet EPA regs for exhaust emissions it may not run right because it's too warm this time of year. Depending on where you live the elevation and time of year may make a difference. Think about where you live and where this engine was tuned at the factory.
If this blower is only a year old a slightly dirty but not plugged up carb can make a difference. Considering the virtually new condition of the machine I think I'd press the issue with the dealer. When these things leave the factory they're adjust within an inch of being too lean. Your area may need a richer condition.
Lastly, I would not do anything drastic until it's colder than a witches t*t and it surges up and down like this. Still the same problem but the cold weather is what you want to tune it for.
stromr is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowblower Forum : Snow Blower Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome