leaking red fluid - Snowblower Forum : Snow Blower Forums
 
LinkBack Thread Tools
post #1 of 2 Old 11-13-2016, 12:51 PM Thread Starter
Junior Member
 
Join Date: Nov 2016
Location: Buckhorn, ON Canada
Posts: 1
Post Thanks / Like
Thanks (Given): 1
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 0
leaking red fluid

Hi... my 2006 or 2007 9HP/27" Craftsman Snow King (Tecumseh engine) has developed a bity of a leak. It's a hydrostatic tranny and it seems very slow to engage both forward and reverse.... after warming up a bit it works OK but I'm concerned about lack of oil in the tranny. I can't see any plugs or places to 'top it off'... it must be a sealed unit. It doesn't drip anymore... I think I lost a few ounces (noticed on the plastic liner I park it on)... the model is 944.524490 (bought from Sears Canada). Unfortunately I misplaced the manual after moving :-(( and probably doubt it would have much info on a 'non-serviceable' item...if that's the case. I'm wondering if it can be a seal where the axle enters the transmission casing... I don't see any evidence of oil around those ares but it may be close to empty now. Any suggestions would be welcome and if do come across a manual I will scan and post it for others. Even another model (if it has the same tranny) would be helpful. thanks.... DG
dishgawd3472 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 11-13-2016, 05:14 PM
Senior Member
 
POWERSHIFT93's Avatar
 
Join Date: Dec 2013
Location: PARADISE CITY, MN
Posts: 9,060
Post Thanks / Like
Thanks (Given): 480
Thanks (Received): 341
Likes (Given): 290
Likes (Received): 1095
Could be a seal and it only drips in the summer when you could care less about snow. also might be a gasket where the 2 halfs are slapped together and that also leaks when you are not watching it. you do not want to run those puppies dry that is 4 sure. better get down and dirty on the floor and do some detective work on that puppy. anyhoo ALOHA from the paradise city.

Long LIVE THE POWERSHIFT!! MAY IT NEVER RUST IN PEACE!!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
MAHALO!!!!!!!!!
POWERSHIFT93 is offline  
Post Thanks / Like - 1 Thanks, 0 Likes, 0 Dislikes
Thanks dishgawd3472 thanked for this post
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowblower Forum : Snow Blower Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome