Cub Cadet 524 SWE - Snowblower Forum : Snow Blower Forums
 
LinkBack Thread Tools
post #1 of 6 Old 12-01-2017, 06:41 PM Thread Starter
Junior Member
 
Join Date: Dec 2017
Posts: 3
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 0
Cub Cadet 524 SWE

I bought a Cub Cadet 524 SWE less then 10 months ago. Maybe ran it 6-8 times last winter. Got it out last week and started it, ran for a few minutes to make sure it was ready to go and turned it off. I walked by it today and its leaking oil from the base of the engine I think and not around the oil drain. Has anyone else seen this? Can't find receipt either. What would have caused an oil leak all of the sudden?

Photos Here

https://www.dropbox.com/s/e0qph51hmj..._5766.JPG?dl=0

https://www.dropbox.com/s/p4k8wv72zd..._5765.JPG?dl=0

Last edited by 1381plater; 12-01-2017 at 06:46 PM.
1381plater is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 12-01-2017, 06:51 PM
Senior Member
 
Cardo111's Avatar
 
Join Date: Feb 2015
Location: The Lower Hudson Valley, NY
Posts: 1,052
Post Thanks / Like
Thanks (Given): 52
Thanks (Received): 124
Likes (Given): 78
Likes (Received): 166
Just to make sure are you sure all the oil port plugs on the engine are tight? The reason I ask is those Powemore engines sometimes have a dipstick fill point and other ports in case they are used for a different piece of equipment. Is it possibly leaking down from the valve cover, because leaking from the bottom unless the drain plug is loose is highly unlikely unless the engine was possibly pierced with a sharp object.

Regarding the loss of your receipt unless you paid cash for it or bought it privately from another person and not an authorized dealer, there should be a record of your purchase. I would contact your dealer or big box if it's not a simple fix it is certainly still under the 2-3 year manufacturer's warranty.

Ariens Platinum 24 SHO w/369cc carbureted LCT motor


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Cardo111 is offline  
post #3 of 6 Old 12-01-2017, 08:12 PM Thread Starter
Junior Member
 
Join Date: Dec 2017
Posts: 3
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 0
Bought it with Credit Card at TSC. All oil ports are tight. Original oil is still golden in color. Maybe base of drain tube?

Last edited by 1381plater; 12-01-2017 at 08:22 PM.
1381plater is offline  
post #4 of 6 Old 12-01-2017, 08:57 PM
Banned
 
Join Date: Sep 2010
Location: Michigan
Posts: 1,585
Post Thanks / Like
Thanks (Given): 3
Thanks (Received): 158
Likes (Given): 95
Likes (Received): 302
Take

Last edited by jtclays; 03-13-2018 at 03:34 PM.
jtclays is offline  
post #5 of 6 Old 12-01-2017, 09:08 PM
Senior Member
 
Cardo111's Avatar
 
Join Date: Feb 2015
Location: The Lower Hudson Valley, NY
Posts: 1,052
Post Thanks / Like
Thanks (Given): 52
Thanks (Received): 124
Likes (Given): 78
Likes (Received): 166
jtclays made a good suggestion, check that as well. Can't hurt to make sure the drain tube is tight, it should be factory tight especially if the oil plug hasn't been removed yet, but you don't know for sure until you check. Good luck with this and keep us posted.

Ariens Platinum 24 SHO w/369cc carbureted LCT motor


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Cardo111 is offline  
post #6 of 6 Old 12-10-2017, 11:09 AM Thread Starter
Junior Member
 
Join Date: Dec 2017
Posts: 3
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 0
Guess what. I took it in and they didn't find any problems. They removed a couple covers and didn't see anything. They wiped off the oil, ran it for 40 minutes off and are giving it back to me. I have a feeling its a slow leak on the main case seal, probably at the base of the engine. Not the crank seal, not the oil drain tube.
1381plater is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowblower Forum : Snow Blower Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome