930 SWE rolling and drive issue - Snowblower Forum : Snow Blower Forums
 
LinkBack Thread Tools
post #1 of 1 Old 03-07-2018, 10:27 PM Thread Starter
Junior Member
 
Join Date: Mar 2018
Posts: 1
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 0
930 SWE rolling and drive issue

Hey guys, newbie here.
I have a 930 swe, I think we got it in 2007, its had a rough life. I replaced the motor on the second year due to oil starvation from our VERY steep 900 ft driveway. Shooting a piston rod out of the side is not fun when there is 2 feet of snow. Anyways, recently I have noticed that when I start it up and let it warm up, the thing tends to roll on its own. I dont remember this happening in the past but I could just be getting old.

The other issue is it seems to take a while for the drive to engage. I usually have to give it a few pushes and then from that point on it is okay. I did replace the drive belt last year. When I roll it on the auger housing and remove the bottom plate, I can hear the gears lock up but with a little more force on the tires they spin almost freely.

any help would be greatly appreciated.
Thanks
nepatitan is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowblower Forum : Snow Blower Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome