engines etc. - Snowblower Forum : Snow Blower Forums
 
LinkBack Thread Tools
post #1 of 5 Old 02-21-2018, 08:27 PM Thread Starter
Senior Member
 
leonz's Avatar
 
Join Date: Dec 2014
Location: New York State
Posts: 1,141
Post Thanks / Like
Thanks (Given): 72
Thanks (Received): 88
Likes (Given): 75
Likes (Received): 158
Question engines etc.

I was wondering if any of you have the Briggs and Stratton 14.5 snow engines on your
snow mules and what you have thought of them so far?????
leonz is offline  
Post Thanks / Like - 1 Thanks, 1 Likes, 0 Dislikes
Thanks Windmount thanked for this post
Likes Windmount liked this post
Sponsored Links
Advertisement
 
post #2 of 5 Old 02-21-2018, 08:31 PM
Senior Member
 
tpenfield's Avatar
 
Join Date: Feb 2015
Location: Massachusetts
Posts: 1,040
Post Thanks / Like
Thanks (Given): 48
Thanks (Received): 56
Likes (Given): 127
Likes (Received): 190
Garage
I have one on my Troy-Bilt 2410 (re-power)

Plenty of power and starts easily.

Not the best quality in terms of engine internals, but it gets the job done. Mine tends to burn more oil than the older engines and the china branded engines that I have.

Regards, Ted
.
Current & Past Fleet:
2017 Husqvarna ST224 (SOLD)
2014 Troy-Bilt 2410 w/ Briggs & Stratton 305cc Engine
2003 Ariens ST824LE (SOLD)
1999 Toro PowerShift 824 w/ 318cc OHV Tecumseh Engine
1988 Toro 521 w/ 212cc Predator Engine
1985 Toro 3521 w/ 179cc Powermore Engine (SOLD)
tpenfield is offline  
post #3 of 5 Old 02-21-2018, 10:03 PM
Senior Member
 
GoBlowSnow's Avatar
 
Join Date: Sep 2015
Location: Colorado
Posts: 1,527
Post Thanks / Like
Thanks (Given): 4
Thanks (Received): 83
Likes (Given): 56
Likes (Received): 249
I run several 1450s and they purr along just fine. There is a smell of oil burning on start up, so I keep an eye on the oil level. This seems to be common with all the B&S engines I'm running.
GoBlowSnow is offline  
post #4 of 5 Old 02-25-2018, 08:18 PM
Junior Member
 
UPtrapper123's Avatar
 
Join Date: Feb 2018
Posts: 7
Post Thanks / Like
Thanks (Given): 6
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 1
I have a briggs 14.5 on my Ariens 28 PRO. Starts first pull and plenty of power. No complaints here!
UPtrapper123 is offline  
post #5 of 5 Old 02-25-2018, 08:24 PM
Banned
 
Join Date: Sep 2010
Location: Michigan
Posts: 1,585
Post Thanks / Like
Thanks (Given): 3
Thanks (Received): 158
Likes (Given): 95
Likes (Received): 302
I'v654

Last edited by jtclays; 03-13-2018 at 05:32 PM.
jtclays is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowblower Forum : Snow Blower Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome