Powersmart DB7659-22 Hunting/surging - Snowblower Forum : Snow Blower Forums
 
LinkBack Thread Tools
post #1 of 4 Old 10-31-2016, 02:28 PM Thread Starter
GAR
Senior Member
 
GAR's Avatar
 
Join Date: Nov 2014
Location: Michigan
Posts: 250
Post Thanks / Like
Thanks (Given): 63
Thanks (Received): 18
Likes (Given): 246
Likes (Received): 149
Garage
Powersmart DB7659-22 Hunting/surging

I don't normally touch these big box blowers but I was at a guys house who offered to sell me this 2015 Powersmart 208cc 22" #DB7659 two stage snowblower for $50, he said he could never get it to run right and it chews up the auger belt ever time he used it. Well I figured out the belt problem right away, the pulleys did not line up. Spacers were put in the wrong place, I assume the factory made this mistake. The surging or hunting I have read is a commen problem with these LCT engines. I pulled the carb and fully took it apart and cleaed it, put it back on and that helped with the hunting/surging and will run the engine smooth now with chock fully on. Threre is No throttle and NO adjustment screws on the carb, I put in a new sparkplug and made sure it was gapped correctly, I checked the govern set up and it all matches the manual but it still surges/hunts and only runs smoth with chock on.

So, with all that said....What do you think of drilling out the jet a little bit. Do you guys think that would help with this hunting problem. This machine is basically new, used only a few times...Sad it's having this many problem...But I would like to fix it, any help would be appreciated.
Attached Thumbnails
Click image for larger version

Name:	image.jpg
Views:	56
Size:	339.9 KB
ID:	91242  

Last edited by GAR; 10-31-2016 at 03:34 PM. Reason: Correcting
GAR is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 10-31-2016, 05:29 PM
Senior Member
 
stromr's Avatar
 
Join Date: Jul 2016
Location: CNY
Posts: 485
Post Thanks / Like
Thanks (Given): 12
Thanks (Received): 38
Likes (Given): 11
Likes (Received): 63
these "new" carbs with no adjustments are the EPA mandated exhaust emissions rules now. had one of these on a neighbor's single stage I messed with 2 winters ago. it would actually run fine when under a load, no choke needed. as soon as it went back to no load condition it surged again. on these constant RPM carbs you can try enlarging the mainjet but be careful. you'll need a set of number drills to get small enough sizes. also don't forget, you probably can't duplicate the smooth bore of the jet with a drill since a drill invariably leaves a swirl pattern. it's a long tedious job but it might work. after much wrenching and drilling I got my neighbor's to run a lot better but not being able to ream the hole smooth there was some inconsistency in fuel delivery.


or you could look around for an adjustable carb.
stromr is offline  
Post Thanks / Like - 1 Thanks, 0 Likes, 0 Dislikes
Thanks GAR thanked for this post
post #3 of 4 Old 10-31-2016, 05:57 PM
Senior Member
 
Join Date: Mar 2015
Location: nova scotia-south shore - ave annual snowfall 199.4 cm ( 78.5 ")
Posts: 2,339
Post Thanks / Like
Thanks (Given): 73
Thanks (Received): 157
Likes (Given): 377
Likes (Received): 603
Garage
would one of those ebay adjustible carbs be an option on that one ?

24 " 1967? Ariens Sno thro
28 " Ariens Sno Tek
Toro CCR ss
1966 Gravely LI Walk behind with dog eater

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
nwcove is online now  
post #4 of 4 Old 11-01-2016, 02:30 PM Thread Starter
GAR
Senior Member
 
GAR's Avatar
 
Join Date: Nov 2014
Location: Michigan
Posts: 250
Post Thanks / Like
Thanks (Given): 63
Thanks (Received): 18
Likes (Given): 246
Likes (Received): 149
Garage
Ok, update. I pulled the carb off once again. I took the main jet out and used the smooth end of my drill bits to find the size of the jet hole. I then use the size that just fit in the jet hole and put the drill bit threw the jet hole BEFORE turing high speed drill on...(I use air tools). I then ran the drill about 5-7 seconds and turned it off, then pulled the drill bit out...I shaved off very little brass and opened the jet hole up very little.....Cleaned it with carb cleaner and blew it out with air hose. I then reassemble carb and put it back on the machine......BAM, sure enough this worked....The engine runs perfect now. I can't say this fix will work on other similar engines but it did on mine. I figure I had nothing to lose, if this did not work I would have just ordered a new carb. I let it run for 10-15 minutes, walked it around with the auger engaged and it did not even sputter...Now, let's how it stays this way when blowing snow under a load...LOL.

Stromr , thank you for your advice on this. I hope the information i am sharing helps others with this similar problems...But, like I said. This fix may not be the problem with your machine and drilling out the main jet could cause you further problems..If you do it, be prepared to replace jet or the entire Carb...
GAR is offline  
Post Thanks / Like - 0 Thanks, 2 Likes, 0 Dislikes
Likes stromr, classiccat liked this post
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowblower Forum : Snow Blower Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome