New to forum, just bought a used 10527 husqvarna. A few questions - Snowblower Forum : Snow Blower Forums
 
LinkBack Thread Tools
post #1 of 6 Old 02-10-2019, 02:48 PM Thread Starter
Junior Member
 
Join Date: Feb 2019
Posts: 6
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 0
New to forum, just bought a used 10527 husqvarna. A few questions

Hey guys I just bought a used husqvarna 10527 snow blower. The previous owners said they used it maybe once or twice ever. You look In The schute and the blades and I donít see even a rock chip so this thing is like brand new. It has sat for just a couple years and I checked the oil and it is right to where it should be and itís clean(itís not black) I grabbed some sea foam and and put a cap full in the tank and then filled it up. Here is the problem Iím trying to figure out and when ever I search it it only talks about the starter. What my problem is is when I hook the power cord up to it. The starter button is hard. It does not push down at all. It feels like a rock. .so I have been looking up information about the starter button and nothing come up. Does anyone have any advice on what is should do or how to fix it? Is that a easy fix?
Munzy is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 02-10-2019, 03:56 PM
Senior Member
 
Cutter's Avatar
 
Join Date: Mar 2017
Location: Regina,Saskatchewan,Canada
Posts: 270
Post Thanks / Like
Thanks (Given): 76
Thanks (Received): 10
Likes (Given): 105
Likes (Received): 110
Garage
Quote:
Originally Posted by Munzy View Post
Hey guys I just bought a used husqvarna 10527 snow blower. The previous owners said they used it maybe once or twice ever. You look In The schute and the blades and I donít see even a rock chip so this thing is like brand new. It has sat for just a couple years and I checked the oil and it is right to where it should be and itís clean(itís not black) I grabbed some sea foam and and put a cap full in the tank and then filled it up. Here is the problem Iím trying to figure out and when ever I search it it only talks about the starter. What my problem is is when I hook the power cord up to it. The starter button is hard. It does not push down at all. It feels like a rock. .so I have been looking up information about the starter button and nothing come up. Does anyone have any advice on what is should do or how to fix it? Is that a easy fix?

This forum is a treasure chest full of good advice, and you'll learn more than you ever thought you would. It's excellent....keep an eye on your post,a nd maybe someone will have an answer for you.

Life is short, so if you don't have the strength to laugh at yourself,
call me.....I'll laugh at you!
2014 Ariens Deluxe 28 with 291 CC Engine
2011 John Deere JS36 Self Propelled Mower
Too many Craftsman Mechanic/Yard tools to mention
Cutter is offline  
post #3 of 6 Old 02-10-2019, 05:09 PM
Senior Member
 
e.fisher26's Avatar
 
Join Date: Nov 2016
Posts: 552
Post Thanks / Like
Thanks (Given): 6
Thanks (Received): 41
Likes (Given): 33
Likes (Received): 51
If the button is on the top of the eng (tecumseh) Thoes buttons freeze up inside if itís not used. eBay usually has a used starter setup or the button housing used. If itís the LCT eng the button and starter should be available new and used


Noma 10/29
Cub cadet 5/26 conv to 8/26
Toro 8/24
Husqvarna st230p
e.fisher26 is online now  
post #4 of 6 Old 02-10-2019, 05:32 PM
Senior Member
 
e.fisher26's Avatar
 
Join Date: Nov 2016
Posts: 552
Post Thanks / Like
Thanks (Given): 6
Thanks (Received): 41
Likes (Given): 33
Likes (Received): 51
Tecumseh



Noma 10/29
Cub cadet 5/26 conv to 8/26
Toro 8/24
Husqvarna st230p
e.fisher26 is online now  
post #5 of 6 Old 02-10-2019, 06:05 PM Thread Starter
Junior Member
 
Join Date: Feb 2019
Posts: 6
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 0
Ok now I fixed the starter and itís all working in that area. Now the problem is the carver story. Anyone know the exact part number I need for a carberator for this thing at all.
Munzy is offline  
post #6 of 6 Old 02-10-2019, 06:08 PM
Senior Member
 
e.fisher26's Avatar
 
Join Date: Nov 2016
Posts: 552
Post Thanks / Like
Thanks (Given): 6
Thanks (Received): 41
Likes (Given): 33
Likes (Received): 51
Take a pic of the eng and the info sticker on the bottom of the eng cover.


Noma 10/29
Cub cadet 5/26 conv to 8/26
Toro 8/24
Husqvarna st230p
e.fisher26 is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowblower Forum : Snow Blower Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Similar Threads
Thread Thread Starter Forum Replies Last Post
New to the forum - Lots of Vintage REO questions connecticut52 New Member Introductions 26 03-14-2015 05:45 PM
bought new Husqvarna 300 series LouF General Snowblower Discussion 8 11-28-2014 04:07 PM
Just Bought Honda HS928TA - a few questions DonDavis Honda Snowblowers 18 11-22-2014 04:27 PM
New to forum...Just bought Toro 421 Blower... 87iroc Toro Snowblowers 12 12-11-2013 10:08 PM
Hi I am new to the forum and just bought a Honda HS622 Yesterday ComicDom1 General Snowblower Discussion 7 10-17-2012 12:18 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome