Lawn Boy 720E - only low revs - Snowblower Forum : Snow Blower Forums
 
LinkBack Thread Tools
post #1 of 1 Old 01-17-2018, 02:09 PM Thread Starter
Junior Member
 
Join Date: Jan 2018
Posts: 1
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 0
Lawn Boy 720E - only low revs

My Lawn Boy 720E starts well, however as soon as it starts up the revs go right down to low.
They do not build up again to where they are strong enough to blow snow. Strangely, if I tip the blower forward the revs go right back up, only to go back to low when the machine is brought back to level - eventually over about 15 ins the machine dies completely - is this a symptom of being clogged or dirty? or is it something else?
Thanks in advance.
mikeaw is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowblower Forum : Snow Blower Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome