Troy Built Idles High - Snowblower Forum : Snow Blower Forums
 
LinkBack Thread Tools
post #1 of 2 Old 02-01-2015, 01:37 PM Thread Starter
Junior Member
 
Join Date: Feb 2015
Posts: 1
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 0
Troy Built Idles High

Thanks for having a look.

My Troy Built Snow Blower doesnt always run high but today was the worst. Used it yesterday with no problems but when i started it up today it idled higher then it runs normally. this has happened before but i just put the snow to her and she eventually powered down but sure can take the snow. but today it wasnt slowing down and started smoking black.

Eventually when it did drop down to idle normally it would only sputter when it would take a load of snow not rev up that i was normally use to. so would like some ideas on the problem.

Thanks
RoGuEIoN is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 02-01-2015, 01:43 PM
Moderator
 
Shryp's Avatar
 
Join Date: Jan 2011
Location: Cleveland, OH
Posts: 4,159
Post Thanks / Like
Thanks (Given): 1
Thanks (Received): 196
Likes (Given): 6
Likes (Received): 250
Sounds like the governor linkage is frozen. Be careful running it like that because if the engine runs too high it can basically explode.

Please direct all snow blower questions to the forums and not to me with PMs.
Shryp is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowblower Forum : Snow Blower Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome