1060E 10HP 24" Briggs - New Carb - Snowblower Forum : Snow Blower Forums
 
LinkBack Thread Tools
post #1 of 2 Old 12-17-2017, 12:47 PM Thread Starter
Junior Member
 
Join Date: Dec 2017
Posts: 2
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 0
1060E 10HP 24" Briggs - New Carb

Hello,

My snowblower is model 1694440
The engine is a Briggs and Stratton 20G414 0111E1

I installed a new Briggs carb (796122) and when I started it up the engine immediately began revving too high (overspeed?).

Can someone help me with instructions for adjusting? Is it the governor?

HELP

Last edited by steevoreeno; 12-17-2017 at 01:26 PM.
steevoreeno is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 12-17-2017, 12:57 PM
Sid
Senior Member
 
Join Date: Jan 2014
Location: LI NY
Posts: 491
Post Thanks / Like
Thanks (Given): 10
Thanks (Received): 23
Likes (Given): 28
Likes (Received): 32
You might have the governor rod on the wrong hole on the carb, or bought a constant speed carb.Others will come on with more detailed advice.
Sid

'66 Sears/Murray 26"
'71 Jakobson 17 SnowBlitz
Sid is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowblower Forum : Snow Blower Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome