Do you have climbing problems with your Simplicity? - Snowblower Forum : Snow Blower Forums
 
LinkBack Thread Tools
post #1 of 2 Old 02-16-2020, 06:53 PM Thread Starter
Junior Member
 
Join Date: Feb 2020
Location: MA, USA
Posts: 15
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 1
Likes (Given): 0
Likes (Received): 1
Do you have climbing problems with your Simplicity?

I've had a 1996-ish Baker 824 (Simplicity 860) for over ten years now, and every one of those years it's be very prone to trying to climb over packed snow instead of plowing through it. I've owned and rebuilt over a dozen snowblowers over the years so I don't think the problem is between my ears. Tried different adjustments of the scraper and skids, different skids, adding weight over the bucket, and even adding some anger. No dice. For a while I've wondered if this has anything to do with the smaller auger they went to around 1990 or whenever they upgraded the gearcase.



Does anyone here have this problem or am I going crazy?






Last edited by BeatsShoveling; 02-16-2020 at 08:01 PM.
BeatsShoveling is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 02-17-2020, 09:37 AM
Senior Member
 
Join Date: Dec 2018
Location: Norway, Asker
Posts: 271
Post Thanks / Like
Thanks (Given): 65
Thanks (Received): 23
Likes (Given): 428
Likes (Received): 171
Garage
climbing

Quote:
Originally Posted by BeatsShoveling View Post
I've had a 1996-ish Baker 824 (Simplicity 860) for over ten years now, and every one of those years it's be very prone to trying to climb over packed snow instead of plowing through it. I've owned and rebuilt over a dozen snowblowers over the years so I don't think the problem is between my ears. Tried different adjustments of the scraper and skids, different skids, adding weight over the bucket, and even adding some anger. No dice. For a while I've wondered if this has anything to do with the smaller auger they went to around 1990 or whenever they upgraded the gearcase.



Does anyone here have this problem or am I going crazy?





I had this problem with my previous Snapper 926, but with my 2011 Signature PRO (looks just like yours) this was way way better and one of the strengts of the machine, that it goes straight thru heavy stuff.

Just my experience.

Dag
Attached Thumbnails
Click image for larger version

Name:	fræssn2.jpg
Views:	16
Size:	112.9 KB
ID:	164045  

2011 Simplicity P1728EX Signature Pro 342cc 11hp (at my house)
2014 Yamaha YT1070 (YT1028) 296cc 9.5 hp (at the cabin)
Dag Johnsen is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowblower Forum : Snow Blower Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome