Starter mount broke - Snowblower Forum : Snow Blower Forums
 
LinkBack Thread Tools
post #1 of 2 Old 02-17-2014, 08:37 AM Thread Starter
Junior Member
 
Join Date: Feb 2014
Posts: 1
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 0
Starter mount broke

I have an older Sno Away 870 with a Tecumseh. This season I went to fire it up and the front starter bolt just fell out, after taking the rest of the starter off I found the mount on the engine block had cracked on the edge and broke off. I attached a picture below. I have to tell you this pull start cold starting is killing my arm lol. I was wondering if anyone had any ideas on how I can fix this.

hevi99 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 02-17-2014, 08:58 AM
mkd
Senior Member
 
Join Date: Dec 2013
Location: midwest ,wisconsin
Posts: 132
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 1
possably tap the hole out enough to replace the bolt you took out with a stud that you can screw in just enough it will stay in place. then take it to a good welding shop and have him braze the stud in place. you then can mount the starter and secure it in place with a nut on the stud instead of a bolt. or have them braze the hole to build up the case and then drill a new hole and tap the hole to install the same size bolt as the original.

Last edited by mkd; 02-17-2014 at 09:00 AM.
mkd is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowblower Forum : Snow Blower Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome