snowbird newbie, lots of questions - Snowblower Forum : Snow Blower Forums
 
LinkBack Thread Tools
post #1 of 4 Old 05-20-2018, 07:26 PM Thread Starter
Junior Member
 
Join Date: May 2018
Posts: 2
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 0
snowbird newbie, lots of questions

i picked up a running gen2, 2 speed 26 " with the tecumseh engine. not sure of the model, looking for a manual i thought it was a 7020, but that manual looks different model . 7040 is closer, but no cigar. mine has 2 belts, not a friction wheel drive. the back cover is missing and i have to make one, but its hard to see how it would look or mount. from the 7040 manual look like it has a cover and a mounting bracket. also, the belts look beat, but also have a lot of slack. very much slack when not engaged, and still pretty sloppy when the lever is forward or reverse. any belts or part numbers available? i assume they are just fractional horsepower belts. i tried the yahoo group, but it seems kind of dead.

if anyone has a back cover and bracket for sale, please let me know


thanks
mike hooker
long island ny
[email protected]
puckhead32 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 05-21-2018, 08:01 AM
Super Moderator
 
sscotsman's Avatar
 
Join Date: Dec 2010
Location: Western NY, USA
Posts: 3,637
Post Thanks / Like
Thanks (Given): 60
Thanks (Received): 330
Likes (Given): 148
Likes (Received): 743
Mike,
Can you post some photos?
If you dont have a way to upload them, you can email them to me, you have my email address! and I could post them here for you..

Scot


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
sscotsman is online now  
post #3 of 4 Old 05-21-2018, 04:06 PM
Banned
 
Join Date: Nov 2016
Location: Glastonbury, CT
Posts: 474
Post Thanks / Like
Thanks (Given): 5
Thanks (Received): 33
Likes (Given): 28
Likes (Received): 68
If not a Yardman 7020 it sounds like it might be a Snowbird 265-2 produced in 1966 the very first year that Tecumseh engines were used. Does the impeller shaft go all the way out to and is supported by the auger shaft?

Last edited by DriverRider; 05-22-2018 at 05:11 AM.
DriverRider is offline  
post #4 of 4 Old 12-26-2018, 06:49 PM
Junior Member
 
Join Date: Dec 2018
Posts: 1
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 0
I have a Snowbird S-225 that I recently had to rip down and clean the points up, once again it starts right up (Engine Model # 100202, Serial # 62-06220). An issue arose that while the engine is running and gear mechanisms disengaged, it wants to lurch or seems to want to engage but doesn't. Additionally, if I engage the gears for forward, no problem, runs like a bear. If I go to reverse, it binds up and stalls, when this happens, the belts seem to jump excessively but stay on the pulleys.
trich is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowblower Forum : Snow Blower Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome