Ariens ST5+2 Troubleshooting - Snowblower Forum : Snow Blower Forums
 
LinkBack Thread Tools
post #1 of 2 Old 12-11-2016, 02:55 PM Thread Starter
Junior Member
 
Join Date: Dec 2016
Posts: 1
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 0
Angry Ariens ST5+2 Troubleshooting

I have a hand-me-down Ariens ST5+2 that is who-knows-how-old. It has been reliable for 6 years for me, but is having some trouble.

When I pump the gas-prime bulb a dozen times as instructed to start the engine, it fires up fairly easily. It then dies out within a few seconds. If I continue to pump the bulb manually, I seem to be able to keep it running almost indefinitely. Any ideas?
ariens5 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 12-11-2016, 05:52 PM
Member
 
Dave9354's Avatar
 
Join Date: Dec 2010
Posts: 55
Post Thanks / Like
Thanks (Given): 3
Thanks (Received): 4
Likes (Given): 4
Likes (Received): 14
Carburetor needs a cleaning. The fuel is not flowing properly.
Dave9354 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowblower Forum : Snow Blower Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome