Governor Adjustment on Techumseh - 5 HP HSSK50 - Snowblower Forum : Snow Blower Forums
 
LinkBack Thread Tools
post #1 of 1 Old 12-13-2016, 06:40 PM Thread Starter
Junior Member
 
Join Date: Dec 2016
Posts: 2
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 0
Governor Adjustment on Techumseh - 5 HP HSSK50

I got a Craftsman 22" snowblower (536886141) on craigslist this past weekend. I've put a new carboratuer on it, along with a gasket, spark plug, fresh gas, and unseized the rusted augurs from the auger shafts. I did a leakdown test, it has around 15% loss. When it idles it seems to hunt a lot, especially when under load. I adjusted the high speed RPM to be screwed all the way in, then 4.5 turns out.

I found a video with the same engine and realized my governor linkage isn't in the same position as what's in the video:

youtube.com/ watch?v=norb3QPKiGs

Here's mine: youtube.com/ watch?v=QLiE6cAfV8k


Does the engine seem to be running too slow or fast? I have a tachometer coming in the mail to check.
mlapaglia is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowblower Forum : Snow Blower Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome