TroyBilt Drive Issue - Snowblower Forum : Snow Blower Forums
 
LinkBack Thread Tools
post #1 of 1 Old 01-21-2019, 06:26 PM Thread Starter
Junior Member
 
Join Date: Dec 2018
Posts: 7
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 4
Likes (Received): 1
TroyBilt Drive Issue

Hey Guys, it's been a while since my last post. I have a +/-6year old TroyBilt Storm 28" blower. When I first start it up and engage the drive it won't move. If I hold the drive lever / clutch down for 30-90 seconds or cycle it a few dozen times it then eventually works just fine for as long as I run it. The colder it is, the longer it takes to move. I would think of it was abad belt or friction wheel it would slip all of the time. Am I wrong? Any ideas?
Axeguy is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowblower Forum : Snow Blower Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome