2410 Troy bilt not running right - Snowblower Forum : Snow Blower Forums
 
LinkBack Thread Tools
post #1 of 5 Old 01-26-2019, 08:46 PM Thread Starter
Junior Member
 
Join Date: Jan 2019
Posts: 11
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 0
2410 Troy bilt not running right

So today I picked up a Troy bilt 179cc 2410 snow blower it was my girlfriends grandfathers it had light use over the last 10ish years it appears but it was stored with gas in it and that had long since went bad before it was drained I threw new fuel lines on it sprayed the carb out with carb cleaner put fresh gas and sea foam in the tank and it fired right up after it was primed now it runs at good speed on the first notch of the choke the next click it runs very high and at full open choke it runs about the same but not as high it’s popping a little from the exhaust the motor runs on it’s own still if I throw the auger on no stalling or hesitating and moves forward and backward in gear with no issues there’s not much adjustment on the throttle it slows down more towards the low setting but not much in the middle anywhere I’m just not sure of the idle issue The snow blower this is replacing was a 5hp toro which I believed to have a bad governor it ran like it was gonna blow up and it couldn’t be put in gear or have the auger put on without applying throttle or it would die and occasionally while using it the idle wouldn’t kick up and it would die my question is where should I go next on the Troy bilt does it sound like a governor or something with the carb or elsewhere?
Jrdriver is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 01-26-2019, 11:31 PM
Super Moderator
 
Kiss4aFrog's Avatar
 
Join Date: Nov 2013
Location: Hudson, WI
Posts: 9,127
Post Thanks / Like
Thanks (Given): 509
Thanks (Received): 679
Likes (Given): 3830
Likes (Received): 1472
Garage
I read your post three times and you ask about an idle issue but I don't understand what problem you're having ?? It doesn't idle, it idles rough, doesn't idle low enough, ... ??
I have a 2410 and usually have to run it with the choke one click on to have it run smoothly. If I take the choke all the way off it hunts like crazy unless it's loaded down with a good amount of snow putting it on the governor.

.

.
Make sure the windows are up before the snow plow goes by !!

Please help keep the lights on by subscribing:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Kiss4aFrog is offline  
post #3 of 5 Old 01-27-2019, 12:44 AM Thread Starter
Junior Member
 
Join Date: Jan 2019
Posts: 11
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 0
It just idles what seems to be extremely high at the second and third click on the choke I’m also noticing some popping and the exhaust is starting to glow a little but yes I agree it runs very nicely at that first click of the choke
Jrdriver is offline  
post #4 of 5 Old 01-27-2019, 01:15 AM
Super Moderator
 
Kiss4aFrog's Avatar
 
Join Date: Nov 2013
Location: Hudson, WI
Posts: 9,127
Post Thanks / Like
Thanks (Given): 509
Thanks (Received): 679
Likes (Given): 3830
Likes (Received): 1472
Garage
It would be the throttle lever you'd use to lower the RPM to it's idle and not the choke. The choke is just for starting it and as it warms up you should be getting to full off/open or if needed like in my case one click shy of full open when warm so it doesn't hunt.

If yours is popping and the exhaust is glowing you might need to adjust the valves.

.

.
Make sure the windows are up before the snow plow goes by !!

Please help keep the lights on by subscribing:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Kiss4aFrog is offline  
post #5 of 5 Old 01-27-2019, 01:25 AM Thread Starter
Junior Member
 
Join Date: Jan 2019
Posts: 11
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 0
I’m also noticing that the throttle doesn’t really adjust much in the high to middle range it’s pretty much the same down towards the end it’ll slow down without stalling till I move it to stop so I’m not sure if it’s the valves or the throttle itself on the carb is stuck
Jrdriver is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowblower Forum : Snow Blower Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome