Starter Motor Issue - Snowblower Forum : Snow Blower Forums
 
LinkBack Thread Tools
post #1 of 1 Old 01-29-2019, 08:17 AM Thread Starter
Junior Member
 
Join Date: Jan 2019
Posts: 2
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 1
Starter Motor Issue

i have an older craftsman snowblower, i would think its an early 90's model, i bought it used about 8 years ago and it has served me very well over the years,


today i tried to use the electric start like i always do, and i can hear the starter motor spinning, but its not turning the engine,


i took the starter off and all the teeth are fine, i think the gear is not "shooting out" to engage the wheel,


is this repairable? or does it need to be replaced?


im a very handy guy with repairs like this
mikey11 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowblower Forum : Snow Blower Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome