New Guy Husqvana 10530 modifications - Snowblower Forum : Snow Blower Forums
 
LinkBack Thread Tools
post #1 of 1 Old 10-02-2014, 09:44 AM Thread Starter
Member
 
Join Date: Oct 2014
Posts: 95
Post Thanks / Like
Thanks (Given): 1
Thanks (Received): 3
Likes (Given): 0
Likes (Received): 2
New Guy Husqvana 10530 modifications

Hi all, I actually trolled a bit to see some recommendations on what to do with my blower before I actually did it. So here was my issues.

Misallignment and bent drive shaft (I bought the blower that way)
Surging Engine
Blade was shot
Impeller could not throw snow anywhere.
Burned out belts like it was noone's business
Sticky Drive triggers
Had a Mouse living in my engine housing... (I think we all know how that went for the mouse hehehehe)
So here were my modifications.
I had a mechanic friend of mine take the drive shaft out and heat and form it so it was straight again, which also helped when we realigned the housing from the impeller to the motor portion of the blower.

Instead of buying a new blade my mechanic just took some scrap steel he had welded it on the old blower blade and sharpened it. It now could probably give most people a good shave!!

Surging Engine was tricky... I thought at first the carb must be gunked up... It was a little bit, but I've seen worse. I cleaned it and adjusted the governing idle screws as well as re positioned the throttle arms. Now it runs with no surging what so ever.

Installed a Clarence Impeller kit. It helped out immensely, but I was still having issues with slipping and burning out belts. (This was actually due to how severely out of balance the machine was, as well as the engine surging probably didn't help)

Sticky Drive Triggers was due to no lubrication on the dogs in the drive lines for the wheels. Just sprayed in Spray Graphite and its beautiful now.

Installed a larger Impeller Pulley on the drive-line side. I went from a 2.75" to a 3.5" On the drive line. Wow... It must have increases RPM by at least 300... It sounds like a bayou fan boat now (with the impeller kit)

Now I still have a small issue/concern. Because I put a larger pulley on the top end of the blower, I no longer can use the idler wheel with the same size belt. In effect it will no longer disengage the impeller/augers (Which I really don't have a problem with) But I am a little worried about one thing.
Since I replaced the pulley and i no longer have to provide the tension coming from the idler wheel, I wonder if there is enough tension on the pulley wheel to keep the impeller going once I get snow in there... Theoretically under load, it could slip again... However, the width of the new pulley is a bit smaller and it really fits in the channel very snug. I can't move the belt by hand to make it slip.

Any thoughts on how to potentially improve this? Thanks
Skeet Shooter is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowblower Forum : Snow Blower Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome