Honda HS80 drive clutch cable problem - Snowblower Forum : Snow Blower Forums
 
LinkBack Thread Tools
post #1 of 2 Old 12-13-2014, 08:33 AM Thread Starter
Junior Member
 
Join Date: Dec 2014
Posts: 1
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 0
Honda HS80 drive clutch cable problem

Hi. New to the forum. Hope someone can help. While using my blower the drive clutch cable became detached from the "cam" up at the handle bar. I can put it back in place but the side of the cam that has a gap to allow the end of the cable to slide in seems to be missing either a clip or bushing of some kind to secure it as the gap/hole is quite sloppy. I've looked at a parts diagram for this unit but don't see anything listed. My only other solution would be to epoxy or weld a washer on the outer side of the cam to secure the clutch cable end. I have replaced both drive and auger belts but cable attachment issue not resolved. Any thoughts?
karoshi is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 12-13-2014, 02:05 PM
Senior Member
 
Normex's Avatar
 
Join Date: Feb 2014
Location: Near Ottawa Ont
Posts: 1,371
Post Thanks / Like
Thanks (Given): 52
Thanks (Received): 85
Likes (Given): 27
Likes (Received): 82
Bump for a new member and Btw Welcome

Snow Removal Apparatus I own:
Ariens ST1530DLE, and good ole arm powered scrapper.
The 15 HP is a new Ducar engine sold
by Princess Auto in Canada.
Normex is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowblower Forum : Snow Blower Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome