toro s620 - Snowblower Forum : Snow Blower Forums
 
LinkBack Thread Tools
post #1 of 1 Old 01-09-2015, 04:43 PM Thread Starter
Junior Member
 
Join Date: Jan 2015
Posts: 1
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 0
toro s620

hello
I have a problem with my toro s620
it has a f style carburetor. I have purchased a new carb kit and installed correctly. I have sprayed carb cleaner into all passages.
I have a problem with starting.

it is extremely difficult to prime. there is a large amount of resistance while priming. after getting it started (which is difficult) it stays running well.

I can snow blow a small amount of snow with no problems.

when I get into deeper snow it dies immediately.

my question is can the governor spring cause it to quit suddenly if it does not maintain tension?

and, I have researched and found that there may be a check ball above the welch plug that may be the cause?

any info is helpful

carb #630932A

thanks
hugeduncan is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowblower Forum : Snow Blower Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome