Need Some Tecumseh Carb Help - Snowblower Forum : Snow Blower Forums
 
LinkBack Thread Tools
post #1 of 10 Old 12-20-2015, 07:05 PM Thread Starter
Member
 
Join Date: Dec 2015
Posts: 46
Post Thanks / Like
Thanks (Given): 21
Thanks (Received): 1
Likes (Given): 1
Likes (Received): 4
Need Some Tecumseh Carb Help

I think my throttle is not opening properly when it should be a full speed. When I push the throttle cable to full speed it looks like the throttle is actually closing to the idle position.

I have a video here that I've tried to capture this happening along with some pictures: https://goo.gl/photos/LYoFpgU4bhkpZVcw8

If I'm correct I'm not sure what to adjust to fix this.

The engine is an HS50 and it's on a 922008. The snowblower is new to me.

Thanks.
Michael303 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 12-20-2015, 07:43 PM
Super Moderator
 
Kiss4aFrog's Avatar
 
Join Date: Nov 2013
Location: Hudson, WI
Posts: 9,137
Post Thanks / Like
Thanks (Given): 510
Thanks (Received): 681
Likes (Given): 3844
Likes (Received): 1478
Garage
The first lever you're moving is the choke. You can see it open and close as it's right at the end of the carb throat.
The second lever is the governor. Be careful with that as you can easily over rev the engine and might damage it. It's how the engine gets more power when needed when you put a load on it like going into heavy snow and you hear the engine try to power up to handle it.
The throttle adjustment will be at the end of the cable running up the handle bars.
The thing in front of the carb is the PRIMER. You hold that black button in so the plate closes off the carbs throat with the ignition off or throttle in the off position and pull the engine over one or two pulls and then try to start it.
Attached Thumbnails
Click image for larger version

Name:	carb controls.jpg
Views:	102
Size:	356.0 KB
ID:	68289  

.
Make sure the windows are up before the snow plow goes by !!

Please help keep the lights on by subscribing:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Kiss4aFrog; 12-20-2015 at 07:54 PM.
Kiss4aFrog is offline  
Post Thanks / Like - 1 Thanks, 1 Likes, 0 Dislikes
Thanks Michael303 thanked for this post
Likes Grunt liked this post
post #3 of 10 Old 12-20-2015, 08:41 PM Thread Starter
Member
 
Join Date: Dec 2015
Posts: 46
Post Thanks / Like
Thanks (Given): 21
Thanks (Received): 1
Likes (Given): 1
Likes (Received): 4
I appreciate the reply. I'm confused because in the video you can see the throttle lever closes to the idle position on its own even though the throttle cable is pulled back into the "fast" position. The throttle cable is set to "fast" through the entire video. I played with the choke to get the throttle lever to open and close for the video.

I'm under the assumption that the throttle should be open when the throttle cable is set to "fast" regardless of load. Is that incorrect? Will the throttle lever open back up under load? I would think the throttle needs to be open to adjust the fuel mix.

Thanks for the explaining how the primer works. I had no idea how it worked and thought it might be missing a bulb or something.
Michael303 is offline  
post #4 of 10 Old 12-20-2015, 08:56 PM
Super Moderator
 
Kiss4aFrog's Avatar
 
Join Date: Nov 2013
Location: Hudson, WI
Posts: 9,137
Post Thanks / Like
Thanks (Given): 510
Thanks (Received): 681
Likes (Given): 3844
Likes (Received): 1478
Garage
The choke is a totally separate lever working the choke plate only. It will not do anything with or to the throttle. The throttle and the choke are independant of each other and each can be in and will stay in a set position while moving the other.

The cable might be backwards, might. But the way to tell is get a flashlight and best to remove the two screws for the primer so it's off and look into the throat of the carb. When the throttle is moved to idle and you look into the carb throat is the throttle plate closed ?? When you move the throttle to fast does the throttle open up ??
The throttle won't open all the way because of the governor and springs. The engine needs to be set to somewhere around 3600/3900 not exactly sure on your specific engine. When you open the throttle to "full" or the "fastest" (Rabbit icon) the carbs throttle plate will NOT be fully open. It opens more IF you have the throttle cable set to fastest and the RPM starts to drop. That dropping RPM causes the governor to pull the throttle plate open a bit more and more to get those RPMs back.

SO ...... no load and throttle cable set to full the engine should be at a controlled 3600/3900 rpm with the throttle plate mostly open but not all the way. If you load the engine with something and the RPM drop then the governor should pull the throttle open more and more to try and get back to that max RPM and once there start to close again to maintain that maximum.

When you were throttling it up unsing your finger on the governor arm that's what it's supposed to do when you have a load and you're losing RPM.
Do it with no load and you over rev the engine and can ventilate the crankcase.

This one looks like it busted the starter and starter bolts off when it let go.


.
Make sure the windows are up before the snow plow goes by !!

Please help keep the lights on by subscribing:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Kiss4aFrog is offline  
Post Thanks / Like - 1 Thanks, 0 Likes, 0 Dislikes
Thanks Michael303 thanked for this post
post #5 of 10 Old 12-20-2015, 10:42 PM
Senior Member
 
Join Date: Oct 2015
Location: Toronto, Canada
Posts: 1,418
Post Thanks / Like
Thanks (Given): 5
Thanks (Received): 112
Likes (Given): 13
Likes (Received): 292
Quote:
Originally Posted by Michael303 View Post
I think my throttle is not opening properly when it should be a full speed. When I push the throttle cable to full speed it looks like the throttle is actually closing to the idle position.

I have a video here that I've tried to capture this happening along with some pictures: https://goo.gl/photos/LYoFpgU4bhkpZVcw8

If I'm correct I'm not sure what to adjust to fix this.

The engine is an HS50 and it's on a 922008. The snowblower is new to me.

Thanks.
Do a search on Youtube for the Donyboy73 videos. He gives a detailed step by step for adjusting governor and carb. Might be a weak governor spring, but its hard to tell without sound on the video, and operating the choke while the engine is warm will just make it sputter and smoke.

Work fascinates me.
I can watch somebody work for hours...
2008 Craftsman 944.528391 (It's a Husqvarna ST227P)
27", B&S 305cc 13.5 ft/lb Torque 9.5 hp
skutflut is offline  
Post Thanks / Like - 1 Thanks, 0 Likes, 0 Dislikes
Thanks Michael303 thanked for this post
post #6 of 10 Old 12-21-2015, 08:35 PM Thread Starter
Member
 
Join Date: Dec 2015
Posts: 46
Post Thanks / Like
Thanks (Given): 21
Thanks (Received): 1
Likes (Given): 1
Likes (Received): 4
Thanks again for the replies. I hunted around to find some videos and articles on how exactly the governor works so now I have a much better understanding and of what's going on. Now I understand in my video that the governor was opening the throttle because the RPMs were dropping when I was closing down the choke. Donyboy73's videos have helped tremendously.

I've only had the opportunity to use the snowblower once. It was about 8-10 inches and looking back now I remember it struggling as it hit deep snow and the RPMs wouldn't maintain so I'm guessing the governor spring needs adjusting.

I've also been struggling with not being able to get the engine to idle in the slow position. My carb rebuild kit showed up in the mail today so hopefully that will help with everything or at least eliminate it as an issue. Is there any way to put load on the engine without snow so I can get the governor dialed in?
Michael303 is offline  
post #7 of 10 Old 12-21-2015, 08:43 PM
Senior Member
 
bad69cat's Avatar
 
Join Date: Nov 2015
Location: Cedar Rapids, Iowa
Posts: 1,237
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 88
Likes (Given): 127
Likes (Received): 277
A pile of dry playbox sand works good just don't get rammy with it......



bad69cat is offline  
Post Thanks / Like - 1 Thanks, 0 Likes, 0 Dislikes
Thanks Michael303 thanked for this post
post #8 of 10 Old 12-21-2015, 09:21 PM
Senior Member
 
Join Date: Oct 2015
Location: Toronto, Canada
Posts: 1,418
Post Thanks / Like
Thanks (Given): 5
Thanks (Received): 112
Likes (Given): 13
Likes (Received): 292
Quote:
Originally Posted by Michael303 View Post
Thanks again for the replies. I hunted around to find some videos and articles on how exactly the governor works so now I have a much better understanding and of what's going on. Now I understand in my video that the governor was opening the throttle because the RPMs were dropping when I was closing down the choke. Donyboy73's videos have helped tremendously.

I've only had the opportunity to use the snowblower once. It was about 8-10 inches and looking back now I remember it struggling as it hit deep snow and the RPMs wouldn't maintain so I'm guessing the governor spring needs adjusting.

I've also been struggling with not being able to get the engine to idle in the slow position. My carb rebuild kit showed up in the mail today so hopefully that will help with everything or at least eliminate it as an issue. Is there any way to put load on the engine without snow so I can get the governor dialed in?
Take pictures of the linkage before you pull it all apart to make sure everything goes back in the right holes. Mark the holes with a sharpie pen. Make sure you get all the little orifices in the jets and body so no stray bits of crap are left. Tiny holes, tiny bits of crap = why does this thing run like crap.

Work fascinates me.
I can watch somebody work for hours...
2008 Craftsman 944.528391 (It's a Husqvarna ST227P)
27", B&S 305cc 13.5 ft/lb Torque 9.5 hp
skutflut is offline  
Post Thanks / Like - 1 Thanks, 0 Likes, 0 Dislikes
Thanks Michael303 thanked for this post
post #9 of 10 Old 12-21-2015, 09:29 PM Thread Starter
Member
 
Join Date: Dec 2015
Posts: 46
Post Thanks / Like
Thanks (Given): 21
Thanks (Received): 1
Likes (Given): 1
Likes (Received): 4
Quote:
Originally Posted by skutflut View Post
Take pictures of the linkage before you pull it all apart to make sure everything goes back in the right holes. Mark the holes with a sharpie pen. Make sure you get all the little orifices in the jets and body so no stray bits of crap are left. Tiny holes, tiny bits of crap = why does this thing run like crap.
Thanks for the tips.

Quote:
Originally Posted by bad69cat View Post
A pile of dry playbox sand works good just don't get rammy with it......
If I took my snowblower to the playground I wonder how long I'd have before the authorities showed up?
Michael303 is offline  
Post Thanks / Like - 0 Thanks, 1 Likes, 0 Dislikes
Likes bad69cat liked this post
post #10 of 10 Old 12-21-2015, 10:27 PM
Senior Member
 
Join Date: Oct 2015
Location: Toronto, Canada
Posts: 1,418
Post Thanks / Like
Thanks (Given): 5
Thanks (Received): 112
Likes (Given): 13
Likes (Received): 292
Quote:
Originally Posted by Michael303 View Post
Thanks for the tips.



If I took my snowblower to the playground I wonder how long I'd have before the authorities showed up?
If you wear a hardhat, a reflective vest, and carry a clipboard, they won't bother ya. Sure you cant find some damp sawdust? Sand will prep the impeller cage for repainting.

Work fascinates me.
I can watch somebody work for hours...
2008 Craftsman 944.528391 (It's a Husqvarna ST227P)
27", B&S 305cc 13.5 ft/lb Torque 9.5 hp
skutflut is offline  
Post Thanks / Like - 0 Thanks, 1 Likes, 0 Dislikes
Likes Kiss4aFrog liked this post
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowblower Forum : Snow Blower Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome