John Deere Snowblower Impeller problem - Snowblower Forum : Snow Blower Forums
 
LinkBack Thread Tools
post #1 of 5 Old 02-13-2016, 11:26 AM Thread Starter
Junior Member
 
Join Date: Feb 2016
Location: North of Toronto
Posts: 2
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 1
Likes (Given): 0
Likes (Received): 0
John Deere Snowblower Impeller problem

Good Day all
I'm a new member, and I'm hoping someone here can help me out with a problem with my snowblower.

I have a second hand John Deere X575 (looks perfect) complete with a 47" Quick-Hitch Snowblower (OMM145749 J1)

It looks in good shape, no obvious dings or dents, but when I was attempting to clean up a small snowfall, I discovered that the impeller would stop - i.e. no power to the impeller, although the auger was working just fine.

I've searched several sites - found a simple exploded assembly drawing, but no direct reference to the impeller - how is it attached etc etc.

I assumed at first that the shear pin had broken, but on closer inspection it appears to be OK. I then though the chain in the chain drive may be off or broken, but thats appears to be OK also. ( disconnected the PTO & turned it by hand & can see that the larger gear & the auger are turning)

I can turn the impeller freely by reaching into the front of the blower, so Im wondering if there might be a key of grub screw associated with the impeller shaft?

If anyone has a suggestion and/or a drawing/diagram of the impeller assembly, I would greatly appreciate any help

Thanks
AncientScribbler is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 02-13-2016, 12:00 PM
Senior Member
 
Join Date: Mar 2014
Location: Lowell area, MA
Posts: 3,246
Post Thanks / Like
Thanks (Given): 118
Thanks (Received): 277
Likes (Given): 358
Likes (Received): 633
First off, welcome to the forum!

From looking here:
OMM145749_K6

It seems to makes reference to a shear bolt for the impeller (though I'm admittedly a bit unclear).

Quote:
2. Remove broken shear bolt (A), one from each end, or one from impeller.
Is that the one you replaced?

I don't know how many users there are here with big blowers for John Deere tractors. You might also try Tractor Forum : MyTractorForum.Com Tractor Forums, if looking for more info.

Ariens 1024 Pro
Toro Power Clear 221QR
Toro Power Curve 1800
RedOctobyr is offline  
post #3 of 5 Old 02-13-2016, 12:06 PM
Super Moderator
 
Kiss4aFrog's Avatar
 
Join Date: Nov 2013
Location: Hudson, WI
Posts: 9,138
Post Thanks / Like
Thanks (Given): 510
Thanks (Received): 681
Likes (Given): 3844
Likes (Received): 1478
Garage
Having trouble finding any information on it.
If you have a diagram can you post or link it ??

.
Make sure the windows are up before the snow plow goes by !!

Please help keep the lights on by subscribing:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Kiss4aFrog is offline  
Post Thanks / Like - 1 Thanks, 0 Likes, 0 Dislikes
Thanks WD_40 thanked for this post
post #4 of 5 Old 11-20-2018, 01:56 PM
Junior Member
 
Join Date: Nov 2018
Posts: 1
Post Thanks / Like
Thanks (Given): 1
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 0
Hi! Two and a half years late, I may have an answer for you or any future tractor enthusiasts with this problem. I had a similar issue, where the impeller just stopped working; the auger spun fine, the main driveshaft turned, but the impeller was free-spinning. I found the link below, which shows a detailed disassembly procedure for the impeller. It appears that most John Deere impellers are plastic, and driven by a hex shaft that connects with the plate holding the shear bolt. If the impeller is loose on its shaft, it can slide backwards and disengage from the hex shaft, freewheeling and being useless. The simple fix is just to yank the impeller forward again, align it with the hex shaft, and slide it back into place. Good luck!

https://www.greentractortalk.com/for...tallation.html
WD_40 is offline  
post #5 of 5 Old 11-20-2018, 02:04 PM
Senior Member
 
micah68kj's Avatar
 
Join Date: Oct 2011
Location: S. C. Pa. 39.755928, -77.577766
Posts: 4,886
Post Thanks / Like
Thanks (Given): 139
Thanks (Received): 270
Likes (Given): 372
Likes (Received): 912
Seems OP stuck his head in the door, asked a question and left. I have no idea whether he ever got his problem solved. That was his only post. Not gonna lose any sleep over it. 💤

Joe

Sent from my junky old Hisense 7" tablet that I can barely see.
Toro 724
Toro CCR 3650E
Toro 5/21 sold
Ariens 5/22 ss ..Sold
Ariens Sno Tek 7/24 sold.
Old green plastic snow shovel... Sent.to shovel Heaven
Old quarry shovel for ice.
New.green shovel
micah68kj is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowblower Forum : Snow Blower Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome