721 QZE Shooting backwards underneath??? - Snowblower Forum : Snow Blower Forums
 
LinkBack Thread Tools
post #1 of 1 Old 12-20-2016, 12:34 PM Thread Starter
Junior Member
 
Join Date: Dec 2016
Posts: 4
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 0
721 QZE Shooting backwards underneath???

I have used this blower several times now. When eating into snow and moving forward blowing there is a constant stream of snow that shoots backwards on the driveway from under neath the blower. This is on flat level blacktop. It is like it is missing a scraper flap or something. Everything is there and I don't see any adjustment. Owners manual is worthless. Any advice? Thanks for any help.
racerdave is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowblower Forum : Snow Blower Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome