1028 lxe - Snowblower Forum : Snow Blower Forums
 
LinkBack Thread Tools
post #1 of 1 Old 10-01-2018, 07:40 AM Thread Starter
Member
 
Join Date: Sep 2018
Posts: 85
Post Thanks / Like
Thanks (Given): 8
Thanks (Received): 3
Likes (Given): 7
Likes (Received): 13
1028 lxe

So after two years of watching my two elderly neighbors actually fight to clear my driveway. Because of surgery on foot two years in a row. I walked to shed. Opened it expecting to find a complete mess. To my surprise it was pretty clear. Looked over the Toro. It was a bit dusty. Checked oil, looked ok. Pulled rope to get oil moving. Moved throttle lever up, plastic part broke off. Pushed primer bulb 20 or so times and pulled rope. She started!!!! Yeh!!! Two years sitting with no movement. I religiously use Stabil in all my equipment. So i think that was the most important thing in it starting.

Sent from my SM-N950U using Tapatalk
robs9 is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowblower Forum : Snow Blower Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome