Toro 522 issue with idle - Snowblower Forum : Snow Blower Forums
 
LinkBack Thread Tools
post #1 of 9 Old 11-19-2014, 10:48 AM Thread Starter
Junior Member
 
Join Date: Nov 2014
Posts: 4
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 0
Toro 522 issue with idle

It has the fixed jet carb so I am not sure how to fix an idle issue. When I initially start up it runs nicely. When I engage the auger there are no issues. I get the the end of my driveway on the first pass and it starts to run funny. It won't throw snow efficiently and gets clogged easily. I am only going through about 6 inches of snow and it is not terribly heavy.

So far I have replaced the carb as the old one was very dirty and it was cheap to put a new one on. I also replaced the spark plug as I didn't know how old it was.

Not really sure what else I can do. Any ideas?
huwge23 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 11-19-2014, 11:06 AM
Moderator
 
detdrbuzzard's Avatar
 
Join Date: Jan 2012
Location: 42.23n/83.33w/636
Posts: 6,572
Post Thanks / Like
Thanks (Given): 213
Thanks (Received): 293
Likes (Given): 1645
Likes (Received): 581
hello huwge, welcome to SBF!! have the belts been changed

current machines
1-toro2450E-38419. 1-toro3000E-38435. 1-toro 3650E-38445
2-toro 521E-38052. 1-toro xl824pt 38086
1-.............,TORO XL 624ps..............
1-............, TORO XL 824ps..............
william
detdrbuzzard is offline  
post #3 of 9 Old 11-19-2014, 01:49 PM Thread Starter
Junior Member
 
Join Date: Nov 2014
Posts: 4
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 0
Thank you and no I have not that make good sense though. I will give that a try.
huwge23 is offline  
post #4 of 9 Old 11-19-2014, 03:51 PM
Moderator
 
detdrbuzzard's Avatar
 
Join Date: Jan 2012
Location: 42.23n/83.33w/636
Posts: 6,572
Post Thanks / Like
Thanks (Given): 213
Thanks (Received): 293
Likes (Given): 1645
Likes (Received): 581
my 521 started running funny just before the belt broke, seeing that it apart may as well change both belts that way you'll know how old they are

current machines
1-toro2450E-38419. 1-toro3000E-38435. 1-toro 3650E-38445
2-toro 521E-38052. 1-toro xl824pt 38086
1-.............,TORO XL 624ps..............
1-............, TORO XL 824ps..............
william
detdrbuzzard is offline  
post #5 of 9 Old 11-19-2014, 03:59 PM
Senior Member
 
POWERSHIFT93's Avatar
 
Join Date: Dec 2013
Location: PARADISE CITY, MN
Posts: 9,172
Post Thanks / Like
Thanks (Given): 480
Thanks (Received): 349
Likes (Given): 290
Likes (Received): 1145
CHECK the impeller bearing also. ALOHA to the forms.

Long LIVE THE POWERSHIFT!! MAY IT NEVER RUST IN PEACE!!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
MAHALO!!!!!!!!!
POWERSHIFT93 is offline  
post #6 of 9 Old 11-19-2014, 04:21 PM Thread Starter
Junior Member
 
Join Date: Nov 2014
Posts: 4
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 0
I will do that as well. I am also suspecting the 5hp is not enough to get through the snow we are dealing with in Buffalo right now.
huwge23 is offline  
post #7 of 9 Old 11-19-2014, 04:48 PM
Moderator
 
detdrbuzzard's Avatar
 
Join Date: Jan 2012
Location: 42.23n/83.33w/636
Posts: 6,572
Post Thanks / Like
Thanks (Given): 213
Thanks (Received): 293
Likes (Given): 1645
Likes (Received): 581
take your time in first gear and don't over work the machine

current machines
1-toro2450E-38419. 1-toro3000E-38435. 1-toro 3650E-38445
2-toro 521E-38052. 1-toro xl824pt 38086
1-.............,TORO XL 624ps..............
1-............, TORO XL 824ps..............
william
detdrbuzzard is offline  
post #8 of 9 Old 11-19-2014, 04:51 PM
Banned
 
Join Date: Feb 2014
Location: Newington, CT
Posts: 2,029
Post Thanks / Like
Thanks (Given): 32
Thanks (Received): 92
Likes (Given): 446
Likes (Received): 148
my toro 824 38080 started doing that, replaced the carb 3 times thinking the ones they sent me were bad, turned out to be a leaking exhaust valve. i said screw it, and just replaced the engine with a 196cc honda clone, no problems yet
43128 is offline  
post #9 of 9 Old 11-19-2014, 06:15 PM Thread Starter
Junior Member
 
Join Date: Nov 2014
Posts: 4
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 0
Quote:
Originally Posted by detdrbuzzard View Post
take your time in first gear and don't over work the machine
I haven't gone over first gear at all and can't go more than a couple feet at a time. It just seems to clog too easily.
huwge23 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowblower Forum : Snow Blower Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome