Steel Drive Disc removal on a 42010 Blower - Snowblower Forum : Snow Blower Forums
 
LinkBack Thread Tools
post #1 of 3 Old 12-28-2017, 08:44 PM Thread Starter
Junior Member
 
Join Date: Dec 2013
Location: Lancaster, New York
Posts: 2
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 0
Steel Drive Disc removal on a 42010 Blower

Hello to everyone!!

Having a part removal problem on a Troy-Bilt, 8HP, Model #42010 Snow Blower. I cannot seem to get the metal disc drive plate assembly out of the unit to replace the bearings. I have removed some parts as much as I dare without messing anything else up.
The attached parts picture shows what I am trying to remove without dropping everything else out of the way. The pivot bolt, (Item 104) along with its associated parts are off. The control link rod (Item #21) is also removed. It looks like the whole assembly should come out once those parts are removed but I still canít get it to budge. Any helpful suggestions will be welcome.

OldDad27
Attached Thumbnails
Click image for larger version

Name:	2013-12-22 22.43.33.jpg
Views:	41
Size:	78.5 KB
ID:	121329  
OldDad27 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 12-28-2017, 09:12 PM
Senior Member
 
Join Date: Oct 2015
Location: Toronto, Canada
Posts: 1,416
Post Thanks / Like
Thanks (Given): 5
Thanks (Received): 112
Likes (Given): 13
Likes (Received): 292
There are a bunch of parts behind that drive disk. You will need to strip the machine down some to get at them by the looks of the parts assembly drawing (link attached). The disk is part number 56 and all the bits that hold it on are shown.

https://www.partstree.com/parts/troy...embly-tractor/

Work fascinates me.
I can watch somebody work for hours...
2008 Craftsman 944.528391 (It's a Husqvarna ST227P)
27", B&S 305cc 13.5 ft/lb Torque 9.5 hp
skutflut is offline  
post #3 of 3 Old 12-28-2017, 09:27 PM Thread Starter
Junior Member
 
Join Date: Dec 2013
Location: Lancaster, New York
Posts: 2
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 0
Hi skutflut,

Yes, I have any possible interfering parts removed, but still can't seem to budge it from that cross support housing. All bolts I could see relative to it are removed.
OldDad27 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowblower Forum : Snow Blower Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome