YT624 Electric Start - Snowblower Forum : Snow Blower Forums
 
LinkBack Thread Tools
post #1 of 5 Old 08-23-2017, 09:22 PM Thread Starter
Junior Member
 
Join Date: Dec 2016
Posts: 8
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 0
YT624 Electric Start

I have another post related to the same machine but different issue. Snowblower is about 3 years old. It?s stored in my heated garage all year round. Every month or so i?ll Start it up, move it around, check operation etc. Today the electric start won?t work. When turning the key all I get is a whining noise from the snowblower. It pulls over ok and starts that way. The LED light comes on when I turn they key...is this a battery issue?
joeymartin is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 08-23-2017, 09:47 PM
Senior Member
 
Join Date: Jun 2014
Location: Shoreline, CT
Posts: 3,447
Post Thanks / Like
Thanks (Given): 103
Thanks (Received): 375
Likes (Given): 467
Likes (Received): 479
It is posible that it is a battery issue. Do you have acces to a jumper box, or jumper cables? If so, you could carefully test it that way. It could also be that the starter solenoid is not operating properly and the starter is only free wheeling....
YSHSfan is offline  
post #3 of 5 Old 08-24-2017, 08:38 AM Thread Starter
Junior Member
 
Join Date: Dec 2016
Posts: 8
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 0
Thanks. I'll do some more troubleshooting when I get a few hours to spend with it.

Does anybody have a service manual for this model?
joeymartin is offline  
post #4 of 5 Old 09-07-2017, 07:09 PM Thread Starter
Junior Member
 
Join Date: Dec 2016
Posts: 8
Post Thanks / Like
Thanks (Given): 0
Thanks (Received): 0
Likes (Given): 0
Likes (Received): 0
Battery is charged and tested fine so that's not the issue. I just learned it has 3 year warranty so back to the dealer it goes for a once over.
joeymartin is offline  
post #5 of 5 Old 09-07-2017, 11:56 PM
Super Moderator
 
Kiss4aFrog's Avatar
 
Join Date: Nov 2013
Location: Hudson, WI
Posts: 9,232
Post Thanks / Like
Thanks (Given): 522
Thanks (Received): 690
Likes (Given): 3912
Likes (Received): 1505
Garage
It might be that the starters drive or bendix needs a little cleaning and or lube. Since it's under warranty might be easier to take it back but if loading and hauling it could be a problem here is a video on the subject if you're interested.


.
Make sure the windows are up before the snow plow goes by !!

Please help keep the lights on by subscribing:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Kiss4aFrog is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowblower Forum : Snow Blower Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome