Snowblower Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
Could use some help...

Bought this Ariens 520E in 2008 new, very little use because it's a second blower and I removed and cleaned out the carb but after reinstalling it, the blower runs slow. I fiddled with the governor a bit to get it to speed up as it wasn't running full speed.

My question is this...can anybody furnish some pics of the governor arm position where it wasn't adjusted (factory setting position) to use as a reference point and also snap a pic of the linkages on the carb end quadrant and the governor end, I may have put the rod back in the wrong hole position although I don't think this is the case.

Any help would be greatly appreciated. (pic taken yesterday is the machine I need the pics for.)

Thanks
http://s149.photobucket.com/user/bills985/media/Moved%20HDT%20pictures/Ariens%20new%20pics%203_zpsnlvnsdif.jpg.html" target="_blank">http://i149.photobucket.com/albums/s45/bills985/Moved%20HDT%20pictures/Ariens%20new%20pics%203_zpsnlvnsdif.jpg" border="0" alt=" photo Ariens new pics 3_zpsnlvnsdif.jpg"/>" media="(max-width: 640px)"> http://s149.photobucket.com/user/bills985/media/Moved%20HDT%20pictures/Ariens%20new%20pics%203_zpsnlvnsdif.jpg.html" target="_blank">http://i149.photobucket.com/albums/s45/bills985/Moved%20HDT%20pictures/Ariens%20new%20pics%203_zpsnlvnsdif.jpg" border="0" alt=" photo Ariens new pics 3_zpsnlvnsdif.jpg"/>" media="(max-width: 960px)"> http://s149.photobucket.com/user/bills985/media/Moved%20HDT%20pictures/Ariens%20new%20pics%203_zpsnlvnsdif.jpg.html" target="_blank">http://i149.photobucket.com/albums/s45/bills985/Moved%20HDT%20pictures/Ariens%20new%20pics%203_zpsnlvnsdif.jpg" border="0" alt=" photo Ariens new pics 3_zpsnlvnsdif.jpg"/>" media="(max-width: 1920px)">
 

·
Registered
Joined
·
3,835 Posts
Unfortunately, you'll probably need to post your picture here directly, or if you can't do that, host it elsewhere. Photobucket no longer allows using their site to serve pictures to other websites, so we can't see the picture.

Edit- Well, I was just seeing the "Photobucket" thumbnail before, but now I see the picture, so maybe something changed, or maybe my computer was being weird.

Posting pics of your current linkage setup might also help. Even if someone didn't have a picture of theirs handy, it's possible someone could look at yours, and figure out if something looks wrong.
 

·
Registered
Joined
·
376 Posts
http://s149.photobucket.com/user/bills985/media/Ariens%20new%20pics%203_zpsnoesp5wy.jpg.html" target="_blank">http://i149.photobucket.com/albums/s45/bills985/Ariens%20new%20pics%203_zpsnoesp5wy.jpg" border="0" alt=" photo Ariens new pics 3_zpsnoesp5wy.jpg"/>" media="(max-width: 640px)"> http://s149.photobucket.com/user/bills985/media/Ariens%20new%20pics%203_zpsnoesp5wy.jpg.html" target="_blank">http://i149.photobucket.com/albums/s45/bills985/Ariens%20new%20pics%203_zpsnoesp5wy.jpg" border="0" alt=" photo Ariens new pics 3_zpsnoesp5wy.jpg"/>" media="(max-width: 960px)"> http://s149.photobucket.com/user/bills985/media/Ariens%20new%20pics%203_zpsnoesp5wy.jpg.html" target="_blank">http://i149.photobucket.com/albums/s45/bills985/Ariens%20new%20pics%203_zpsnoesp5wy.jpg" border="0" alt=" photo Ariens new pics 3_zpsnoesp5wy.jpg"/>" media="(max-width: 1920px)">
I really like the look of this blower. Perfect size for what I needed. Unfortunately couldn't find anything like it. Had to go bigger.
 
1 - 3 of 3 Posts
Top