Snowblower Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello- the paddle on my 721R continually spins. I have plenty of slack in the control arm cable. Can anyone comment on this? Only 2 years old.
Thanks
 

·
Account closed by member request.
Joined
·
9,612 Posts
It could be that you are missing a return spring. also a lot of slack in the cable means it is more than likey done for.
 

·
Registered
Joined
·
1,431 Posts
Hello- the paddle on my 721R continually spins. I have plenty of slack in the control arm cable. Can anyone comment on this? Only 2 years old.
Thanks
Remove side cover where belt is and see if the tension mechanism is jammed up. Operate the control arm and see what's moving to put tension on the belt. Tension pulley is probably stuck with tension on, spring may be missing or broken and the cable isn't really doing anything.

https://www.toro.com/en/parts/partdetails/?id=42803 should be the drawing you need to look at to find the lever etc that probably needs to be removed, so you can clean the shaft and lubricate it, check the spring etc.
 

·
Account closed by member request.
Joined
·
9,612 Posts
Remove side cover where belt is and see if the tension mechanism is jammed up. Operate the control arm and see what's moving to put tension on the belt. Tension pulley is probably stuck with tension on, spring may be missing or broken and the cable isn't really doing anything.

https://www.toro.com/en/parts/partdetails/?id=42803 should be the drawing you need to look at to find the lever etc that probably needs to be removed, so you can clean the shaft and lubricate it, check the spring etc.
Yeahhhh what he just said.:rock:
 
1 - 4 of 4 Posts
Top