Snowblower Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
It ran fine last week when we had about 4 inches and it started first pull today and then it ran for about 2 minutes but while throwing some snow it just seized up. Pull start wont budge. I took off electric start and that's not it. I took spark plug out and it looks fine but I can't turn the engine at all. Has oil, has gas. Any thoughts? I have 3' feet to clear...:(

I read that maybe it froze so I moved it inside to see if that's the issue. Doesn't look like it, in the video it just wont go past that certain point almost as if it's seized but I'm not sure how that could happen.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6 (Edited)
It's about three years old. Doubt it. :-( I no next to nothing about engines so I don't even know where to start. What's the blower?

Here's another when the electric start back on: It spun a little more but then quickly stopped again.

 

·
Registered
Joined
·
1,740 Posts
I asked about the warranty...so that when we start throwing suggestions at you, you don't void it.

this is a situation where you want to stop trying to use the electric starter.

Try removing the shroud that goes over the flywheel...something (loose bolt, etc.) may have gotten in there and jammed the flywheel against the shroud (or ignition coil)...unlikely but worth a shot. Take a lot of pictures in case you have to remove linkages, etc. in order to get the shroud off.
 

·
Retired Moderator
Joined
·
4,160 Posts
First thing to do would be remove the belts. That way you can know for sure if the issue is the engine or something in the drive system. In general the auger belts get disconnected when the auger handle is not down, but the wheel drive belt is always connected to the friction disc transmission section. The drive clutching happens further down the system.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #10
Soo....after I paid a guy $75 to plow my driveway I come in, push the button and it moves. Put it back together and just used it for 15 minutes no issues. :censored::censored:

Well,I guess I should be happy it's fixed but I just wasted money and time from what I can gather was just some frozen parts? How can I snow blower freeze?! :eek: I parked the beast in my house for the night so it works tomorrow, is there a trick or something to parking the thing after using it?
 

·
Registered
Joined
·
78 Posts
Thinking your auger brake pad [located low inside belt cavity] may have gotten wet and froze in the stop position....Next time need to use, before doing anything and eng off, have someone partially squeeze the auger handle [to release the brake], while you reach in the chute and verify the auger will spin..Auger will not spin when handle is fully depressed or fully untouched..IMO
 

·
Registered
Joined
·
550 Posts
If it was frozen, from ice it would have NOT worked and then stopped.

Something else is causing it to lock up. Like classiccat said about a loose bolt, or in the blower drive. One thing for sure it's not internal to the engine.
 

·
Registered
Joined
·
374 Posts
That knock in your 1st video is definitely a knock coming from inside the engine crankcase. Why it would run after sitting for maybe few hours......I'm lost on that one.
but there is something wrong inside that crankcase. You have two options.....run it until it throws whatever is in the way thru the case. Or take it to a small engine shop, let him tear it down.
 
1 - 14 of 14 Posts
Top