Snowblower Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
hey gang, Bought this a couple weeks ago and it looks like someone has been in it before. I don't believe the throttle/ gov linkage is all there.


I did get this running. the intake valve retainer was broke in half. but I only found the one half. guessing someone pulled it out. I think it would be too large to fall into the sump.


so $35 for thrower and $2.14 for the retainer and she runs. all gears work as well as auger and diff lock. cleaned up well.


is there a thread on here with proper linkage installation like pictured?
 

Attachments

·
Registered
Joined
·
11 Posts
Discussion Starter #2
oh yeah. note to self. watch how deep the threads are on your compression gauge. mine made contact with the valve. glad I used the pull start.
also, here is a pic of the broken keeper I found.
 

Attachments

·
Registered
Joined
·
11 Posts
Discussion Starter #3
I have this thing running pretty good right now. but my WOT is too high. still questioning the Gov linkage. anyone have pix of theirs for reference? Tecumseh 8hp
 

·
Premium Member
Joined
·
722 Posts
Does it have a small torx screw on the throttle lever, with a spring under it? I can't see if it does on any of you pictures. On new Tecumseh's they do, and its the high speed adjustment.
 

·
Registered
Joined
·
871 Posts
you should have 2 wire rods connected to the gov arm. pics of throttle lever and throttle linkage would help.
i just installed a carb on my 10hp tec, should be similar to yours, vid will show the linkages(2 rods) , 1 from throttle lever to gov arm and 2nd from gov arm to throttle plate. installing a digital tach will confirm if rpm is too high, should be max ~3600rpm



digital tach install

 

·
Registered
Joined
·
2,284 Posts
Hello LONG, that spring you have in the first picture is for the engine mounted throttle control lever, as seen in the attached video.


 
1 - 6 of 6 Posts
Top