Snowblower Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
75 Posts
Discussion Starter #1
Yo so my Deluxe 28 started revving really high and sounds somewhat violent not surging but just revving much higher than normal. Could this be caused by the belts? When I took the belt cover off the top there was quite a bit of black rubber. The belts don't look terrible to me but I don't really know what I am looking for. They don't look frayed but maybe the drive belt is a little worn but the auger belts look pretty good. Any ideas?

Also how do you get the throttle/choke knob off does it just pull straight up? Seems like it wants to break if pulled too hard.
 

Attachments

·
Registered
Joined
·
75 Posts
Discussion Starter #2
Heres some pictures. A lot of rubber... can't tell the condition of the belts in these but they don't seem terrible to me. Could a worn belt cause the engine to rev high or am I off base and something is wrong with the engine it self? Gonna try to get a video. I am afraid to run it for too long don't want to damage it further.
 

Attachments

·
Registered
Joined
·
1,811 Posts
Not sure on the revving but the choke knob has a little plastic tab that clips in a hole on the carb lever, Best I do is wiggle it and hope for the best, fuel shutoff is the same, Broke one on the fuel but needed to replace the shutoff anyway and made sure to order one with a knob, but once you get that off the throttle knob just slides off, Choke knob holds it on so no issues getting that off.
 

·
Premium Member
Joined
·
1,080 Posts
I would be checking out the throttle and governor linkages for the high revving.

The belts are probably a symptom rather than a cause.
 

·
Registered
Joined
·
75 Posts
Discussion Starter #5
I would be checking out the throttle and governor linkages for the high revving.

The belts are probably a symptom rather than a cause.
Thanks for the reply. The linkages are all connected properly and turning the engine speed knob does increase the rpm and turn the governor. It just sounds so violent. Anything specific I should be looking for with the linkages?

Going to post a video soon.

I noticed the oil seems a little over filled and there is some white sludgy stuff on the cap and top of fill tube. Could this be the problem?
 

·
Registered
Joined
·
75 Posts
Discussion Starter #7

Here is a video of the blower. I guess its not really revving high its just so loud. Keep in mind this is at Idle speed its much louder if you turn the speed up
 

·
Premium Member
Joined
·
1,080 Posts
So it is not revving high . . . just making a noise.

Remove the belts and see if it still makes the noise. If so, you know it is not the belts. Does not sound good though . . .
 

·
Registered
Joined
·
2,438 Posts
i will agree, its not revving high, just sounds like a terrible rattle in something, hopefully its not engine internals.
 

·
Super Moderator
Joined
·
9,891 Posts
I can hear a tinny noise which usually is a bearing. I'd check that tensioner pulley with the belt off, the one right under the crankshaft pulley. Just give it a spin and see if it makes noise.
Secondly the bearing down below for the drive disc. There is a knocking that just isn't right in that video. Problem is we pretty much need to be there to find it.

.

.
 

·
Registered
Joined
·
2,312 Posts
Plus the engine is vibrating, looks like the shaft is moving and vibrating. For cheap, use a wooden dowel as an earpiece touching parts of the engine, for something better go to Harbor Freight.
 
1 - 11 of 11 Posts
Top