Snowblower Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I had posted this on the repair forum, but figured I would re post here hoping that some other Ariens owners would have some input:


Hi Guys,

This is my first post. I just purchased a 2009 Ariens Deluxe 30 with very low hours on it. I picked it up for $600.00. It looks and runs like new, except for the remote wheel lock seems to stick. It sometimes takes a few pulls to get it to engage or disengage. I have not tried adjusting the cable as per the manual yet, that is my next step. It does seem like the cable has plenty of tension, and the lock just resists freeing/locking. I did try greasing it. The blower has been sitting for a bit, and things are a little dry. I have also seen conflicting information on how to use the remote lock. I have read that you squeeze it, release, turn then squeeze it again, but I have seen a Youtube video where the user squeezed it during the whole turn, then released it, then squeezed it again to reengage the second wheel. My next step is to put it in the service position so I can give everything a proper greasing. How do you guys usually drain the tank before doing it? Sorry for the long first post. I would appreciate any input from anyone with Remote lock experience.

Thank You,

Scott
 

·
Registered
Joined
·
27 Posts
Scott,

I have a new 2012 Deluxe 28 and experienced the same issue with the remote wheel lock. It is inconsistent in it's lock and release mechanism. I have found that you need to trigger it while the wheels are moving. So in other words, you need to anticipate your turns a little bit. I also greased it and checked it out completely. It seems to be a bit flaky in it's operation, but with some practice it does what it should.
 
1 - 2 of 2 Posts
Top