Snowblower Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Ive got the cheaper version of the SnoTek 24...foreign motor/plastic shoot.....Just had it serviced in November...its surging as it runs at idols....less surge when it is blowing snow. I changed the plug and drained the carborator twice and it still seems to be running awful...any ideas on where i should go from here.?? Anyone experience the same issues? Purchased this unit last winter about half way thru...so the **** thing should be running like a dream...
 

·
Registered
Joined
·
3,193 Posts
It sounds as though the atmospheric vent in the carb is blocked or constricted. Hopefully someone with more knowledge of the particular model of carb, will be able to chime in and point out where it may be located.
 

·
Registered
Joined
·
1,371 Posts
Ive got the cheaper version of the SnoTek 24...foreign motor/plastic shoot.....Just had it serviced in November...its surging as it runs at idols....less surge when it is blowing snow. I changed the plug and drained the carborator twice and it still seems to be running awful...any ideas on where i should go from here.?? Anyone experience the same issues? Purchased this unit last winter about half way thru...so the **** thing should be running like a dream...
Welcome to the forum, it sounds very much you might need a good carb cleaning. Was some gas left from last year? and with Stabil?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Yeah....there was some gas left in it without stabil...when it was serviced they cleaned the carb and all that jazz....its been progressively running worse..or im simply noticing it more... I put new gas in it and have probably ran it 4-5 hrs of use so far...it also is giving me a bit of a "poof" back fire kind of noise ..almost sounds like its struggling to get gas..no fuel lines are cracked or leaking..everything looks good as far as that goes....

I'm running it on choke click 3 of 4 from left to right....everywhere else it runs worse ....Which choke click should it be running great from?
 

·
Registered
Joined
·
1,371 Posts
At this point just run it with the choke setting it runs best at but there is a thorough carb clean in the book for it as today's gas contain ethanol and this is what gums up your carb. When you buy gas for your snow blower don't keep it for more than 30 days then dump it in your car or truck and buy some more. Many put Stabil with their gas purchase. At the end of the season just run it out of gas with the gas valve off and drain your tank completely as this will help greatly for the next season start.
In the meantime for now you may want to get some carb cleaner Sea Foam and run with it for a while and see if the problem goes away. Good Luck
 

·
Registered
Joined
·
3,193 Posts
You should not have to use the choke at all to get it run properly. By forcing the engines suction to pull fuel into the carb, instead of gravity, it makes me believe that the service that you had overlooked the atmospheric vent. By using the choke, you will probably force the engine to run rich, and as a result will run slower than optimum. This will result in a reduced machine performance. Over time, you may also find that the spark plug will not perform as expected, and carbon build up on your exhaust valve.
 

·
Premium Member
Joined
·
5,205 Posts
I just bought a 2 yr. old Sno Tek 24. Runs like a scalded dog. Only had about half a tank of gas run through it by the P.O. Brought it home, filled it with gas and away we went.
Maybe you just need to get a little Seafoam™ run through it to clean in up a bit.
 

·
Retired Moderator
Joined
·
4,160 Posts
Sounds like the original poster needs to open his jets up a little. It is just how all the lean EPA engines are these days.
 
1 - 9 of 9 Posts
Top