Snowblower Forum banner

1 - 12 of 12 Posts

·
Premium Member
Joined
·
5,202 Posts
If'it was not interfering before something changed... What changed? You may have to repeat the process to make that determination. I've had a couple of them apart but never had this problem.
 

·
Registered
Joined
·
402 Posts
Discussion Starter #3
If'it was not interfering before something changed... What changed? You may have to repeat the process to make that determination. I've had a couple of them apart but never had this problem.
Only thing that I did was replace the emulsion tube, and the jet needle
 

·
Super Moderator
Joined
·
9,892 Posts
Did you compare the old one to the new one ??

Did you remove the plate from the shaft, any chance you put the plate back on the wrong side of the shaft ??
 

·
Registered
Joined
·
402 Posts
Discussion Starter #5
Did you compare the old one to the new one ??

Did you remove the plate from the shaft, any chance you put the plate back on the wrong side of the shaft ??
They looked close enough, so I didn't bother measuring, or anything. Didn't do anything with the plate.
I'll try taking some pics tonight.
 

·
Retired Moderator
Joined
·
4,160 Posts
I have heard that style needs the emulsion tube removed before the bowl is removed. If you don't do it in the right order you can bend the emulsion tube.
 

·
Registered
Joined
·
3,192 Posts
Eh, we've all been there. I might suggest an inexpensive jewelry cleaner. Please look up on you tube using them for carb cleaning. You will be amazed.
 

·
Registered
Joined
·
402 Posts
Discussion Starter #12
Hopefully now that I got it running we don't have use a snow removal service as per my mother-in-law/ land lady's threats.
 
1 - 12 of 12 Posts
Top