Snowblower Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
709 Posts
Discussion Starter #1
Hi All,

I'm helping a friend with a go-kart with a Tec 640025C carb and I thought this is the place to ask. It was a MESS but I have it straightened out except the primer won't prime. It's not split or cracked, and I can pass air through the vent in the throttle bore and it comes out in the bowl area under the welch plug. What am I missing? It seems like if there was a restrictor in the port in the throttle bore, it might help.
 

·
Registered
Joined
·
2,237 Posts
  • Like
Reactions: Kiss4aFrog

·
Registered
Joined
·
709 Posts
Discussion Starter #3
That's a nice article. What I did was disassemble and soak what I could, and scrubbed the rest. The bowl gasket is a bit rough but with the bowl on, it's tight. I see in there how the primer is supposed to block the port to force air into the bowl. I'll look it over again.
 

·
Registered
Joined
·
709 Posts
Discussion Starter #4
Thanks for the inspiration. I was able to dig out the retainer and see inside the chamber and everything seemed fine.... EXCEPT... one of the screw holes that holds the air filter housing goes directly into the center so if the screw is out, NO PRIMER!!! I've thrashed this a bit and I thought I had tried with all the screws in, etc, but it works now!!
 

·
Registered
Joined
·
2,237 Posts
Glad to hear you got it figured out nt40. I know Briggs pulsa prime carbs need the air cleaner screw in to work correctly,and I didn't remember\know that the TEC carbs were that way. Thanks for the info.
 
1 - 5 of 5 Posts
Top