Snowblower Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I am new to this forum so that you in advance for any help.

I was clearing my driveway a few weeks ago and stepped on this part as I was finishing up. I am unable to identify the part and where it possibly came from off my snowblower. Any ideas?
 

Attachments

·
Registered
Joined
·
1,020 Posts

·
Registered
Joined
·
1,020 Posts
It looks almost like a pivot rod?

I found this with your numbers, Model # 24788190 CRAFTSMAN Snowthrower, Gas.
CRAFTSMAN SNOW THROWER Parts | Model 24788190 | Sears PartsDirect

Open it up and click on the HAND CRANK ASSEMBLY DIAGRAM.
Then scroll down to part number 11.
What do you think?

It connects up top I don't see how something is not working right with it out?
 

·
Registered
Joined
·
2,224 Posts
:welcome: to SBF jeggspuehler.
Do all of the functions on the snow blower work? The auger turns, the wheels drive the machine forward and back?

The parts list shows item #27 (wheel clutch cable) as possibly the found piece. They call it a cable but it could also be a rod like you found. It also shows a spring on one end which may have broken and is still attached to the drive plate bracket. If everything works on your machine, I would guess it is from something unrelated to your blower.

MTD 247.88190 (31AS6HEG799) - Craftsman Snow Thrower (2005-2) (Sears) Drive Assembly Diagram and Parts List | PartsTree.com

I agree with Big Ed, looks like part number 11. We were typing at the same time, but he correctly identified it.
 

·
Premium Member
Joined
·
62 Posts
Pivot rod upgrade MTD Service Kit 753-04882C

jeggs,

Please check this out. MTD Service Kit 753-04882C
This is a kit to replace the pivot rod. It seems to have an extra screw to hold the pivot rod in place. Not sure about your model year but it seems to apply to 2004 - 2006 vintage. At the very least, it gives very detailed instructions for re-assembly. If you google the item number you should be presented with the pdf.

I was not able to provide a proper link for you, as google got in the way...

Here is the description of the kit.
PURPOSE: Snow thrower models manufactured between 6/21/2004 through 8/01/2006 may experience the auger
clutch (LH) handle not releasing freely when the wheel drive clutch (RH) handle is released. The problem may be
the mechanism interlocking the wheel drive clutch motion to the clutch lock cam on the auger clutch (LH) handle.
Inspection and diagnosis of the problem should be performed prior to installation of this kit to ensure that
the pivot rod/clutch lock components are the true cause.
 

·
Registered
Joined
·
1,020 Posts
Thanks Big Ed. It was the pivot rod. I don't see how this could have fallen off. Now just have to figure out how to get it back together. I really appreciate the help!
I don't see how all the rest that it hooks up to is still working?
 

·
Retired Moderator
Joined
·
4,160 Posts
Yea reason everything appears to work fine is it looks like part of the one handed interlock system that is designed to hold the auger handle down as long as you have the drive lever held down.
 

·
Registered
Joined
·
1,020 Posts
Yea reason everything appears to work fine is it looks like part of the one handed interlock system that is designed to hold the auger handle down as long as you have the drive lever held down.
It is a good thing he didn't run it over and have it get sucked up into the auger.
$23 bucks for the parts doesn't look bad?
But he has the rod?
 

·
Premium Member
Joined
·
62 Posts
A new rod is part of the kit , probably not same as the original.
 

·
Registered
Joined
·
2 Posts
It is a good thing he didn't run it over and have it get sucked up into the auger.
$23 bucks for the parts doesn't look bad?
But he has the rod?
Two years after this thread - a few days ago the pivot rod falls out but all I know is that the auger is clunk-clunk-clunking. I look in and see this black pencil sized object wrapped around shaft. I can't break it or bend it so I hacksaw it off. Then I notice that the handle lock system is acting goofy. First the auger control level won't stay down. Then it stays stuck in the down position. After some inspection today and finding this thread I realize that it was the pivot rod that was wrapped around the shaft. So I ordered the kit. I'll let you know how the install goes.

Cheers
 
1 - 15 of 15 Posts
Top