Snowblower Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Good Day!

As per the title, my discharge chute on my snow blower will no longer turn. When I pull (or push) the handle for adjustment. I can hear the gear grinding/clicking. I took apart the top cover, removed the chute and removed the gear/bearing assembly. The gear that is attached to the cable moves freely when the chute gear assembly is removed. This led me to check the other gear assembly, which was seized. A metal plate surrounding the plastic/rubber (i think) gear was rusting badly. I cleaned it up and lubricated it but even after putting it back together it will not move. I have been trying to find a replacement part with no luck. Any ideas?

I have a Briggs & Stratton 800 Series, 22" width.
The engine runs fine.

Any help would be appreciated.

Cheers,
 

·
Premium Member
Joined
·
5,202 Posts
Welcome to the forum.
Hopefully someone will be along soon with advice. I know absolutely zero about Briggs machines. Maybe you can post a few pics of the chute rotation assembly too?
 

·
Premium Member
Joined
·
4,811 Posts
you said the other gear assembly was seized but you cleaned it up. then it moved freely? what did you clean it up with?

did you also clean up the runner that the chute moves on? and then greased? does the chute move freely when you took the gears off away from it?

is anything bent that would hold things up?

I would try cleaning things up again and inspecting the whole thing to determine how it is hanging up before you start replacing parts.

any pictures ?
 
1 - 3 of 3 Posts
Top