Snowblower Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
I've got a snapper 4220 with what I believe is a 4hp Tecumseh. It needs new belts. I've got what I think are the correct belts. 3/8 x 34 and a 1/2 x 35. I cannot find a routing diagram. The manual I found online doesn't appear to have one.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
Seems like the 3/8 x 34 is too long and the 1/2 by 35 is a hair to short. I can't get enough slack to get the auger to not spin
 

·
Registered
Joined
·
83 Posts
I have the exact same machine and even with the OEM belts the auger doesn't disengage. I have done some research and I think I need I new brake tube. I hope this solves the problem.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #13
Snapper belt fit much better. Its still spinning the auger just enough to throw a mist of light snow when disengaged. I'm going to grab some of the fuel hose someone mentioned in another thread and see if that doesn't take care of it.
 

·
Account closed by member request.
Joined
·
9,612 Posts
Snapper belt fit much better. Its still spinning the auger just enough to throw a mist of light snow when disengaged. I'm going to grab some of the fuel hose someone mentioned in another thread and see if that doesn't take care of it.
what do you mean by that.:confused::confused::confused::confused::confused::confused::confused::confused::confused::confused::confused:
 

·
Registered
Joined
·
2,246 Posts

·
Registered
Joined
·
2 Posts
Auger problem Snapper 4220

I just picked up an old Snapper 4220. One side of the auger spins. The other one doesn't. I can't seem to find a service manual. DOes anybody have a clue about how to fix this?
 

·
Banned
Joined
·
4 Posts
This replacement belt works with select Swisher finish cut mowers. And they help ensure long life of your Machine.
 
1 - 20 of 20 Posts
Top