Snowblower Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Forget to ask in my previous post.

I will be installing an impeller kit in my 726. It has a 4 vane auger. Do I need to install on all 4 vanes or will just two on opposing vanes suffice?

Thanks.
 

·
Premium Member
Joined
·
3,452 Posts
In my experience on an even number of impeller blades you only need 2. (you can always install the others later if you are not completely satisfied with the results, but you have to keep it balanced meaning doing in in opposite pairs).
On an impeller that has an uneven number of blades you have to install the kit on all blades to keep the impeller balanced.
 

·
Super Moderator
Joined
·
6,669 Posts
hello old deere, welcome to SBF
 

·
Premium Member
Joined
·
232 Posts
I say do all four. If you don't do it initially it will never get done.I don't care what they say but 4 is better than 2 hands down. I have all 4 on my blower.
 

·
Premium Member
Joined
·
5,202 Posts
Welcome tk the forum, from the Keystone State.
 

·
Premium Member
Joined
·
163 Posts
Welcome to the Funny farm, oopps i mean forum.
I did all 4 on my JD1032.


Lee
 

·
Registered
Joined
·
19 Posts
Discussion Starter #10
Thanks to all for the welcome and advice. Will either buy or make a set for 4 blades. If I get lazy: I'll put only 2 and keep the others for spares. Whats the best if I buy? Prefer to buy in Canada only because of the ridiculous shipping costs across the border. I often travel to New England and would buy there in person if available.
 

·
Premium Member
Joined
·
163 Posts
I haven't bought a kit. I just made my our with the info i
found on this site. I used a rubber mud flap. One thats not
to thick. Cut the pieces. Used a gasket punch for holes.
Drilled the holes in the impeller blades and nut and bolted
with stainless 1/4 bolts. might have taken a little over an
hour to do.


Lee
 
1 - 14 of 14 Posts
Top