Snowblower Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
My MTD, S640F, snow thrower was stuck in high gear. I opened it up and found that the pin going to the friction wheel assembly had come out. I put it back in and it came out again. There doesn't appear to be any way to connect it to the shift arm assembly. Am I missing something? I couldn't figure out how to insert a picture so here are links to the pictures of the problem. Thanks.
https://photos.app.goo.gl/RakgEY739fB7Mnfv5
https://photos.app.goo.gl/Wojjeh1CsjgEC4QC7
 

·
Registered
Joined
·
2,258 Posts
Spot welds are broken. Gonna have to weld it back together.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
OK, thanks! I wasn't sure if there was something missing. I have a small mig welder that I am not very good with, but I can probably tack it back on. :)
 

·
Registered
Joined
·
686 Posts
You might want to grease that hex shaft a little the friction wheel rides on...make sure you cover drive disc.


Skip ad and Forward to 2:51 of video and watch to 5:37..... Helped me.



 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
You might want to grease that hex shaft a little the friction wheel rides on...make sure you cover drive disc.


Skip ad and Forward to 2:51 of video and watch to 5:37..... Helped me.



https://www.youtube.com/watch?v=lorbol4sUdw
Haha, great minds think alike! I watched this video yesterday :)
I cleaned off the hex shaft with som power blaster and wiped some lube on it. I can't believe how smoothly the assembly runs now.
 
1 - 6 of 6 Posts
Top