Snowblower Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Ariens 921022 brand new. As part of the assembly you are supposed to check that the dual handle interlock works. If both clutches are depressed and then you release the right one(accessory) while keeping the left one(traction) depressed, the accessory is supposed to stay engaged. Mine doesn't. It releases and the blades stop spinning.

If indeed this is not the proper way for this to work does anyone know what the fix is?

I would just as soon make the adjustment myself and not have to go through the hassle of returning to a dealer unless necessary.
I may just not get it fixed unless it is a pita to use it this way.
Thanks for any ideas.
 

·
Registered
Joined
·
82 Posts
It should work as you described, you can check to see that the interlock is working under the dash - see pic.

My Ariens should have the same mechanism and with the drive depressed I have to press the auger lever down until I hear a click. There really is no adjustment since it's a plate with a spring attached that locks both levers. The only thing I can think of is if the locking mechanism on the shaft is cracked since its only plastic.

Hope this helps!
 

Attachments

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks frons, that helped.
In the picture I have drawn a red line approx where the plastic piece has cracked. Where the pin is the piece has cracked wide open!
 

Attachments

·
Registered
Joined
·
27 Posts
Other way around

I have the same model, only 2 years old now... and I believe it's the other way around... if you depress the auger lever and then depress the clutch lever for foward motion the foward motion lever holds down the auger lever. If you let up on the foward motion clutch lever both come up....

maybe they have reversed it.... after reading your post again, it sounds like that's what your describing, so if it doesn't work that way for you, then something is not working properly....

Vermont Ken


Ariens 921022 brand new. As part of the assembly you are supposed to check that the dual handle interlock works. If both clutches are depressed and then you release the right one(accessory) while keeping the left one(traction) depressed, the accessory is supposed to stay engaged. Mine doesn't. It releases and the blades stop spinning.

If indeed this is not the proper way for this to work does anyone know what the fix is?

I would just as soon make the adjustment myself and not have to go through the hassle of returning to a dealer unless necessary.
I may just not get it fixed unless it is a pita to use it this way.
Thanks for any ideas.
 

·
Registered
Joined
·
1 Posts
Handle interlock issue also

FRONOS4, I would like to thank you for posting your picture. I just got to use my Brand new Platinum 24 in the Jonus Noreaster JAN23rd. The interlock would only work occasionally. I looked at the mechanism late last night and could not figure it out. Seeing your picture, the lobe for my auger has the same position as the drive so who knows how it worked at all. I bought this at a dealer so I would not have these issues. THANKS
 

·
Registered
Joined
·
5 Posts
Sorry for the ancient thread revival.


I just wanted to thank all involved for posting their pics and info. Helped me out a lot.


I too bought a brand new machine from a dealer so I would not have to deal with this kind of stuff. Machine was working fine for the first couple hours. Now it's not.


Turns out the pin is completely missing from the auger drive cam. I must have broken, then fell out somewhere.
 
1 - 7 of 7 Posts
Top