Snowblower Forum banner

1 - 20 of 50 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
Just joined the forum and have a coworker that gave me an old 1983 Dynamark X12 26" 8hp snow thrower that i want to get up and running before it snows again here in central ohio

This is what he told me that it would run but he had to run it rich to keep it running and then it got to the point where it would not run.

He could get it to run if he sprayed starting fluid in it but only for few seconds so he tried to rebuild carb with no luck so he bought a new carb that is on it now and he still cant get it to run gave it to me. he said it has spark and will fire up with starting fluid with the new carb but won't run with out it. has old gas in it with stabli in it.

First off I am an industrial maintenance manager been doing maintenance on big stuff all my life and working on my harleys so i know my way around tool box.

So my thoughts are this.
1. Drain all the gas clean it out replace with fresh gas
2. Clean the bowl and jets and needle valves
3. Put in new spark plug
4. fire it up see what happens.

Question anything on these machines that i may have missed in my initial thoughts.
 

·
Banned
Joined
·
2,029 Posts
thats the same way i would do it. i would recommend splurging on an ngk br2lm, it sparks hotter, lasts longer, and will make the engine easier to start and run better
 

·
Registered
Joined
·
1,020 Posts
Does it have a fuel shutoff valve?
It helps to have that open. (you would be surprised at some folks lack of knowledge):p

A kink in the fuel line or a collapsed line?
Is there a fuel filter on it?

I would just try new gas first and see what happens then go from there?
 

·
Registered
Joined
·
1,740 Posts
Just joined the forum and have a coworker that gave me an old 1983 Dynamark X12 26" 8hp snow thrower that i want to get up and running before it snows again here in central ohio

This is what he told me that it would run but he had to run it rich to keep it running and then it got to the point where it would not run.

He could get it to run if he sprayed starting fluid in it but only for few seconds so he tried to rebuild carb with no luck so he bought a new carb that is on it now and he still cant get it to run gave it to me. he said it has spark and will fire up with starting fluid with the new carb but won't run with out it. has old gas in it with stabli in it.

First off I am an industrial maintenance manager been doing maintenance on big stuff all my life and working on my harleys so i know my way around tool box.

So my thoughts are this.
1. Drain all the gas clean it out replace with fresh gas
2. Clean the bowl and jets and needle valves
3. Put in new spark plug
4. fire it up see what happens.

Question anything on these machines that i may have missed in my initial thoughts.
Welcome to SBF!!!

on #2, get yourself a carb rebuild kit as well. I'm suspecting a bad bowl gasket, bowl nut gasket and/or intake gasket...plus what the other guys said :D
 

·
Registered
Joined
·
29 Posts
Discussion Starter #8
Thanks everyone i will check all those items. Hoping to get started on it tomorrow after work ill keep you all posted on progress and for your advice. Just picked it up few min ago here are some pics of the old bird.





 

·
Registered
Joined
·
1,020 Posts
I would guess that the choke cable is working the choke properly?

The carb is new, I would just give her fresh gas and see what happens.
I wonder why he didn't try that? It is the easiest thing to do.
 

·
Registered
Joined
·
29 Posts
Discussion Starter #10
he has another snowblower and was tired of messing with it i think and just wanted it out his way. Im going get new plug gas and see what it does then go from there new carb is on it old carb in box he gave me.
 

·
Registered
Joined
·
3,192 Posts
It's also missing the carb shroud.

I'm wondering if the carb was either not setup correctly, or someone tinkered with it
 

·
Super Moderator
Joined
·
6,669 Posts
change the fuel line while you are doing maintenance, just like on the Harley the fuel line will go bad
 

·
Registered
Joined
·
1,020 Posts
Looks like a new gear box on the auger shaft? New gears?
 

·
Registered
Joined
·
29 Posts
Discussion Starter #14
Update: Its running. But needs some adjusting.

Ok so got home today flushed carb and gas tank and put in new plug and it fired right up but went wide open had to pull plug wire to get it shut off.

I tinkered some more and found the throttle control that links to the engine not sure what you call this was not right i tightened it up and was able to control the throttle better still don't have full range of full throttle fast and stop had to choke it out to stop it now.

I was able to get it to stay idling and have minimal throttle drive it around and throw about 3 ft path of snow. But i have to get the engine throttle control and actual throttle control right so i can have fast medium and stop or off. other than that it runs pretty good.

Here are some pics of the linkage i am having issues with. and the little spot of snow i did lol.

Where it goes into the engine was way loose so it was doing nothing and on the next pic where it goes down side of engine to carb its rubbing on breather tube and the throttle at the handle and this piece are not working in together as they should to get full throttle and stop or shut off.



 

·
Registered
Joined
·
29 Posts
Discussion Starter #15
Found this picture it looks like what i have on my carb set up and i know i need to do some adjustments between the main throttle control the carb and the wires going to the crankcase.
 

·
Registered
Joined
·
29 Posts
Discussion Starter #16
so now that i have educated myself some i realize that the pcs that was loose is the governor ( Like said long time maintenance guy very little small engine knowledge but im learning quick)

So i will be working on getting the governor and the throttle working correctly together tomorrow. I don't think the guy before me messed with the set point on the governor itself i just think he has the linkages not right so the throttle and governor are not working right together initially it rev way high because it was way loose but once i got the fixed it runs just is not reving up when deep snow or when throttle is pushed to max so its not all moving together correctly.
 

·
Registered
Joined
·
1,536 Posts
It's apparent that our machines came from the same place or share DNA somehow. Take a look at the panel

VS

Got to be stamped out at the same line.
I was going to say our carb setup is different, but now I'm wondering if I have ever had the carb cover off this particular machine. If need be I can open mine up and show you how mine is setup. Mine is an old craftsman driftbreaker. My choke however has a wire loop that you pull out (with detents). In other words, no knob.
 

·
Registered
Joined
·
3,192 Posts
Well, to say the least, it appears that the governor arm has been frankensteined together. The bolt that holds the arm to the mounting point, is a little unconventional, and might allow for it to become out of alignment.

In this situation, you might want to find a scrap motor to scavenge parts and pieces from to make this one whole and operational.

You are definitely on a short learning curve, but you are doing fine.
 
1 - 20 of 50 Posts
Top