Snowblower Forum banner

41 - 59 of 59 Posts

·
Super Moderator
toro 928 ohxe 38801,
Joined
·
446 Posts
YES! same as the other there , yet it's also missing some of the cold start enrichment aid , a spring loaded flap that when pushed in with the choke closed allows for even more gas to help in starting in cold temps,
 

·
Super Moderator
Joined
·
2,726 Posts
May or may not be missing something. Depends on whether the lever etc. are present on the right. Looks like it might be there just not visible in the picture
 

·
Registered
Joined
·
1,931 Posts
Ditto on HCPBH .... not all early machines had that spring loaded assist knob. Only my YardMan 7100 has it, none of my others .....
 

·
Super Moderator
Joined
·
2,726 Posts
View attachment 169245
Previously the wire was bare and wrapped around this...
On all the ones I've had, the throttle cutoff either has a threaded screw to hold a ringlet like you have there, or a spade connection. That one looks like something is broken off. If you have an ohm meter, slip a piece of plastic or cardboard between the wire and the throttle and see if you have a circuit from that circular spot and the wire. If so then you might check into drilling and threading a hole to hold the ringlet. Just a thought.
 

·
Registered
Joined
·
17 Posts
Last post everything is put back together both the key shutoff and the throttle shutoff work now, thanks to everyone for the advice!
 

·
Registered
Joined
·
17 Posts
And I am back...my speed selector is not working, I'm not sure if I put it back together wrong or what..help.
 
41 - 59 of 59 Posts
Top