Snowblower Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
79 Posts
Discussion Starter #1
powersmart db7651-24


This came in surging. So I cleaned the carb. Started it up and it ran perfectly. After about 30 seconds, fuel started pouring out of the little hole in the middle of the primer bulb. No biggy...I figured that the needle was not seating properly so I shut the fuel off. Then fuel started pouring out from under the tank. So I'm guessing the fuel shut off valve is shot.

So it was the lesser of two evils...shut the fuel off and deal with the fuel pouring out of the shutoff valve or open the valve, and deal with the fuel pouring out of the primer bulb.

Is it common for the shutoff valve to go on these? Any advice moving forward on this? I got it running so well but created these new problems.

Thanks for any advice.
 

·
Registered
Joined
·
130 Posts
FWIW, I have had problems with leaky shut off valves on my old (mid 80's) Bolens and my present mid 80's Ariens ST824. I think the o-ring dries up or something. I took both of them apart and cleaned them up, one was solved by greasing up the o-ring, the other I had to replace the o-ring with one I got at a Ace hardware store.

K
 

·
Super Moderator
Joined
·
9,892 Posts
If it's the LCT 208cc engine on that it also gets used on Ariens machines so it's unlikely there is anything that's common to go bad on it. Sounds like you have a bad shutoff and a sticky float. Luckily a carb is only $13 on ebay if you needed to go that route. Might just be a sticky needle that can be cleaned.

They seem to be a little difficult to look up parts for. Can't find anything on the fuel shutoff.

.
 

·
Registered
Joined
·
79 Posts
Discussion Starter #4
So I've finally got the time to tackle this thing. But I can't seem to figure out how to get at the bottom of the tank. I hate these crap machines. I've taken off a bunch of hardware but can't seem to get anything to budge. Has anyone ever taken off the gas tank on this thing?
 

·
Registered
Joined
·
79 Posts
Discussion Starter #5
Scratch my last...got the tank off but can't duplicate the leak. No leak now. I want to hit myself on the head with a hammer.
 

·
Registered
Joined
·
79 Posts
Discussion Starter #6
So I think we can mark this post as solved. I took the tank off and tested it and the petcock did not leak. I also took the carb off and the pin that holds the float was sitting at the bottom of the bowl. Strange since I distinctly remember assembling it correctly but maybe I didn't. Who knows. My guess is that since the fuel line slips over the nipple on the tank that when the fuel had back pressure, the joint wasn't really made for that since the hose slips over the nipple.

Long story short, once assembled this time, no leaks. If it ain't broke don't fix it?

All I know is that it runs like a top and no leaks now. Thanks to everyone, once again, for the help.
 

·
Registered
Joined
·
79 Posts
Discussion Starter #8
So when I checked the oil on this machine, I noticed the level was about 2 inches above the high mark on the dipstick. I drained about 34 oz out of it. According to the manual, 16 oz is the capacity. I put 16 back in but it falls just short of the low mark on the dipstick. So I added about another 4 to get it in range.

I'm a little confused as to why 16 doesn't hit the mark. Has anyone ever worked on one of these? Am I being too anal?

Thanks.
 
1 - 8 of 8 Posts
Top